7

Since upgrading to Ubuntu 18.04 from Ubuntu 16.04, the titlebar buttons on the upper left corner of the window for closing, minimizing and maximizing windows have vanished.

enter image description here

Then I went to GNOME Tweaks (GUI menu) --> Windows --> Titlebar
and set the options to add maximize and minimize buttons to the title-bar. However there was no option for Window close button there:
enter image description here

Things I have tried to correct this

  1. I installed gconf-editor and tried this gconf-editor solution
  2. I did not understand the solution (if any) provided here

Output of the command

gsettings get org.gnome.desktop.wm.preferences button-layout

Output: 'minimize,maximize'

7

Your window-control button layout doesn't look right. Run the following command in Terminal to reset it

gsettings reset org.gnome.desktop.wm.preferences button-layout

This should fix the problem. If it doesn't work, then set a suitable button layout manually. For example run the following command

gsettings set org.gnome.desktop.wm.preferences button-layout :minimize,maximize,close

to get the minimize, maximize, close buttons (in this order) at the right end of the title-bar.

Alternatively to get the close, minimize, maximize buttons (in this order) at the left end of the title-bar, run

gsettings set org.gnome.desktop.wm.preferences button-layout close,minimize,maximize:

and so on.

| improve this answer | |
  • Still works for Ubuntu 20.04 LTS. – eduncan911 May 10 at 15:11
  • this worked only once I enabled "Use system title bar and borders" in chrome appearance settings, for Chrome. – FantomX1 Nov 12 at 23:48
1

Things have evolved since then. The solution will likely be a modification of the solution using gconf-editor you referred to. The key nowadays lives in a different place.

Install dconf-editor. Navigate to the key org.gnome.desktop.wm.preferences button-layout. Switch the "Use default value" toggle to "On". The value should become :appmenu,close. If your default would be different (since you upgraded rather than performing a fresh install), then manually enter the value :appmenu,close.

| improve this answer | |
  • Installed dconf-editor, ran it in the terminal, but it is unclear how the options you have specified need to be edited from the menu-tree I get on running: -apps -ca -com -desktop -org -system – ijuneja Sep 1 '19 at 12:05
  • Can dconf reset -f / fix this? – Mido Sep 1 '19 at 12:42
  • 1
    Warning: the command suggested by @mido above would reset all your GNOME settings (customisations you have done). – pomsky Sep 1 '19 at 12:51
  • @pomsky yeah i would suggest backing up settings dconf dump / > settings.txt before resetting – Mido Sep 1 '19 at 12:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.