0

Hello I am trying to open STM32CubeProgrammer on my Ubuntu system. Once I have installed the program, tried to open it and came up with this error:

Screenshot

You are using OpenJDK, Please install OpenJFX

Debian: sudo apt-get install openjfx

or install Oracle JRE

I ran the sudo apt-get install openjfx but still the same problem.

Can somebody help me here? Thank you.

  • Not sure, might you have to set the JAVAFX_HOME environment variable maybe? askubuntu.com/a/1078414/367990 Or try to reboot or log out and back in, if the variable was already added during the installation, but not applied to your session yet. – Byte Commander Aug 23 '19 at 17:05
  • Thanks you for answer, I rebooted but same problem. – fury Aug 23 '19 at 17:07
1

According to the release notes in STM32CubeProgrammer release v2.2.0, under "known problems and limitations", it says

STM32CubeProgrammer does not work under Ubuntu® 18.04.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.