6

I have computer with Intel UHD Graphics 630 (no other graphic card) and Ubuntu 19.04 I've bought monitor Philips 499P9H which has native resolution of 5120x1440 However I cannot make ubuntu to support it, I'm connected with HDMI cable provided with the monitor, I've tried couple of third parties with no change. My graphic card supports this resolution I'm following this advice - https://askubuntu.com/a/818153 However when I add resolution 5120x1440 with different refresh rates - tried from 24 to 60 - I'm getting blank screen with blinking cursor (doesn't appear that resolution was changed)

Monitor runs in 3840x1080 which isn't native for it and everything is super blurry. Resolution selector looks like this:

resolution selector

Can someone please advice what can I do to make ubuntu to support this resolution?

Thank you in advance!

14

According to Intel only HDMI 1.4 at a max of 4096x2304 at 30Hz is possible. And according to Philips your monitor requires HDMI 2.0 or DisplayPort 1.4 to get full resolution.

Thus, you will need to upgrade to a GPU capable of HDMI 2.0 or DisplayPort 1.4, along with a cable to match the specification. Then you should be able to get the native resolution.

  • 1
    nice answer with g00d links.. – PRATAP Aug 23 at 14:59
  • Thanks! This definitely appear to be the case. Do you know will it work on Ubuntu if I'll just get some nvidia card that satisfy the requirement? I.e. is there any issues/conflicts of having 2 cards or having intel card not supporting it etc. – Handsome Jack Aug 23 at 19:46
  • 1
    The NVidia cards probably won't work well with open source drivers. Having a discrete GPU in your system won't be an issue otherwise though (and you should be able to turn off the Intel graphics in BIOS to be sure, and force PCIe usage, to be sure). – dobey Aug 23 at 21:17
  • Yep, I can confirm that external GPU solved the issue! I've bought Geforce 1030 that according to spec can support that high resolution and everything works fine! Open source drivers worked but not too well (even dragging/resizing windows was lagging), proprietary drivers solved the problem! – Handsome Jack Aug 24 at 9:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.