Shotwell will not launch on my Ubuntu 18.04.3 system. I tried launching via terminal and got this response,

** (shotwell:11529): ERROR **: 13:25:29.976: PhotoFileFormat.vala:259: Unsupported file format PHOTO_FILE_FORMAT_UNKNOWN
Trace/breakpoint trap (core dumped)

I have uninstalled (purged) then re installed with the same result.

Any advice?

  • What is the photo format you're trying to import? Try opening shotwell with a log file: SHOTWELL_LOG=1 shotwell This will create a logfile called shotwell.log in the ~/.cache/shotwell folder. Paste the contents of that logfile into a post here. – BashGuy Aug 22 '19 at 13:23
  • the logfile output will not fit in here, too many characters – Brian Murray Aug 22 '19 at 14:08
  • Try editing your post. – JerareYoshi Aug 22 '19 at 14:21
  • Woops, can't seem to get the hang of posting here (first post). I do however have my Shotwell working again. I deleted all references to Shotwell in Nautilus then re installed. Thanks all. – Brian Murray Aug 22 '19 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.