Using Unity in Ubuntu 12.04, the Ctrl+Alt+Num Pad combination for positioning windows no longer works completely consistently:

  • Ctrl+Alt+4 (move window to left half of screen) was changed to Ctrl+Super+Left Arrow.
  • A similar change moved Ctrl+Alt+6 to Ctrl+Super+Right Arrow.

So in 12.04 one moves windows to corners using Ctrl+Alt combos, but Super combos are needed to move to the left or right.

This is more than a convenience problem since the new windows positioning provided by the super key combos seems to give different sizes than the Ctrl+Alt combos they replaced, leading to distracting gaps between windows when you combine the two methods to position three or more windows on one screen.

Is there a way to restore the previous behaviour so that I can use Ctrl+Alt+Num Pad for all window positioning?

  • Since this isn't necessarily read by People In Charge, you might want to ask explicitly if anyone has a workaround or a way to revert to the old behavior. Someone else might have a better suggestion for where to actually send this suggestion.
    – belacqua
    Apr 27, 2012 at 23:14
  • I restored the functionality with the answers below but one thing is still missing. Windows where resized when repeatedly hitting control-alt-9 / 3 / 1 / 7 no rezising happens anymore with 4 and 6.
    – Stephan
    Sep 19, 2012 at 13:33
  • You are right, resizing is missing. Perhaps this feature was removed? Sep 19, 2012 at 13:55

4 Answers 4


Install compizconfig-settings-manager Install compizconfig-settings-manager. Search for "compiz" in the Unity Dash, or start with ccsm from the commandline.


CompizConfig Settings Manager (ccsm) is an advanced tool, and not all of its options are completely compatible with Unity. As such, CCSM has been known to sometimes break users' desktops. Please use caution and know that you are taking a risk by following this answer or any other answer that recommends the use of CCSM. In the event that following this advice does break Unity, please see this question for instructions on how to reset it.

Find the Grid plugin:

enter image description here

Click on the key binding you want to change, click on Grab key combination, and press the keys you'd like to use.

enter image description here

  • Thanks allot! The pictures and apt link are a nice touch. I had previously tried everything in CCSM except Grid because the name seemed to imply moving windows among workspaces. Mar 29, 2012 at 15:13
  • In my case I had already predefined short key for this, but it was different that the others: Ctrl+Super+Left/Right. Super is the Win key it you have that kind of keyboard. Anyway I had to install compiz to see it. Thanks for the answer and screens!
    – kode
    Feb 24, 2014 at 22:32

The shortcuts have been replaced with Ctrl+Super+Left and Ctrl+Super+Right. At the moment, Compiz (Unity's backend) does not support multiple shortcut keys for one action. This may change in the future.

Hold down Super to see them all:

enter image description here

  • 1
    Thank you - really appreciate the informative response and have checked the Ctrl-Super-Left and Right shortcuts work for me. This will be fine for the time being although looking at the forums I can see other comments on the same topic and it would be good if a future release did address this
    – davposs
    May 6, 2012 at 6:50
  • 1
    How would we go about changing the Ctrl + Super + {Left/Right} to make use of the keypad 4 and keypad-6 keys? This is highly annoying, considering that the keypad owns the majority of the window movement commands, but yet the left and right movements are removed and placed on the arrow keys, requiring the user to lift their right hand off the keypad to go to the arrows.
    – Jack
    May 8, 2012 at 4:11
  • see @blackhawkover's answer: change key bindings in ccsm > grid
    – amc
    May 8, 2012 at 5:56
  • 1
    My question already states what the new hotkeys are; I am asking how to return them to their former numpad mappings. Jul 31, 2012 at 13:33

I too had this problem.

You'll need to install compizconfig-settings-manager (CCSM).

In CompizConfig Settings Manager go to "Grid" (near the bottom under Window Management):

ccsm options

Set the bindings (which was not set for me either) to Put Left as Ctrl+Alt+4, and Put Right as Ctrl+Alt+6:

ccsm - grid options

I too would like to see this as a standard put into a patch for put window using number pad.

  • This is the same answer as given by andrewsomething, but a month later. Jul 31, 2012 at 13:34

Have you tried to run a command in the command dash?

Press Alt+F2 and type in following:

unity --reset

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .