35

In 11.10 Using Configuration editor, one used to be able to edit a boolean parameter named : Desktop_Show This allowed to hide/show all desktop icons. This latter was removed in 12.04. Config Editor in 12.04

Someone, knows how to hide desktop icons automatically?

Thanks

  • This looks answered anyway, but that looks like gconf-editor, which is probably why it did not work... – Wilf Dec 17 '13 at 23:40
58

It's in gsettings (& dconf-editor), to do from cli use

gsettings set org.gnome.desktop.background show-desktop-icons false

From gui open dconf-editor (install dconf-tools) as in screen

dconf-editor

  • (Bumpy bump!) When I use this is the final version of Ubuntu 13.04, I can only bring up the launcher one time if the desktop icons are disabled. I then have to alt+TAB to a window, then back to the desktop to bring it up again. The launcher works normally in applications. – Esso May 6 '13 at 14:44
  • It's funny... i had 2 set of icons overlaped on my Ubuntu 16.04 Unity desktop, but when i ran this, one of them disappeared and problem solved :) Thank you! – Marco Oct 19 '16 at 15:04
  • On Ubuntu 16.04, show-desktop-icons seems to get reset to true every time I log out. Additionally, in order to hide the icons, I need to killall nautilus and then restart nautilus after running gsettings set org.gnome.desktop.background show-desktop-icons false. Perhaps I am doing something wrong? – mpb Nov 15 '16 at 1:06
  • This should work in both Unity and GNOME Shell – Flimm Nov 11 '18 at 9:34
2

The MyUnity application (in the software center) has a lot of useful features for customizing Unity, including the ability to hide desktop icons. The newest version supports 12.04.

  • Thanks for the response. I already have MyUnity, Ubuntu Tweak and Unity Settings. What they offer is to show/hide (home, network, trash and computer) icons. While, I am interested in hiding all icons in dekstop (files, folders.....etc). – Hanynowsky Mar 28 '12 at 17:01
0

If you are using the Gnome desktop environment then

  1. Open the Tweak tool
  2. Click on the Desktop tab
  3. Toggle the "Icons on Desktop" button to off.

Tweak Tool settings menu

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.