0

so I've recently built a new PC and kept my SSD/HDD, so everything except my disk drive which has ubuntu installed on it changed. The ethernet connection doesn't work (it used to work on old PC on same ubuntu install), Wi-Fi still works through an USB adapter. Ethernet Connection works on another drive with Windows install so I know the port is working fine, it's only on Ubuntu. I'm looking for a way to get ethernet working without reinstalling ubuntu

my ifconfig:

r0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
    inet6 fe80::3c60:9eff:fe5b:8d94  prefixlen 64  scopeid 0x20<link>
    ether 3e:60:9e:5b:8d:94  txqueuelen 1000  (Ethernet)
    RX packets 40313  bytes 5565185 (5.5 MB)
    RX errors 0  dropped 0  overruns 0  frame 0
    TX packets 1515  bytes 472236 (472.2 KB)
    TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 78701  bytes 6556181 (6.5 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 78701  bytes 6556181 (6.5 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

virbr0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        inet 192.168.122.1  netmask 255.255.255.0  broadcast 192.168.122.255
        ether 52:54:00:71:a9:c1  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlx0024010c2ae6: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.41  netmask 255.255.255.0  broadcast 192.168.1.255
        inet6 fe80::bf4c:1503:726:f000  prefixlen 64  scopeid 0x20<link>
        ether 00:24:01:0c:2a:e6  txqueuelen 1000  (Ethernet)
        RX packets 73240  bytes 82584023 (82.5 MB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 51703  bytes 7315654 (7.3 MB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

as you can see there's no eth0 or eth1 in ifconfig, maybe that has something to do with the problem?

my /etc/NetworkManager/NetworkManager.conf:

[main]
plugins=ifupdown,keyfile

[ifupdown]
managed=false

[device]
wifi.scan-rand-mac-address=no

"sudo lshw -C network" output:

    *-network DISABLED        
       description: Ethernet interface
       product: Ethernet Connection (7) I219-V
       vendor: Intel Corporation
       physical id: 1f.6
       bus info: pci@0000:00:1f.6
       logical name: eno1
       version: 10
       serial: 04:d4:c4:47:ce:15
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=e1000e driverversion=3.2.6-k firmware=0.5-4 latency=0 link=no multicast=yes port=twisted pair
       resources: irq:126 memory:a5200000-a521ffff
  *-network:0
       description: Ethernet interface
       physical id: 2
       logical name: br0
       serial: 3e:60:9e:5b:8d:94
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A link=no multicast=yes
  *-network:1
       description: Ethernet interface
       physical id: 3
       logical name: virbr0
       serial: 52:54:00:71:a9:c1
       capabilities: ethernet physical
       configuration: broadcast=yes driver=bridge driverversion=2.3 firmware=N/A ip=192.168.122.1 link=no multicast=yes
  *-network:2
       description: Wireless interface
       physical id: 4
       bus info: usb@3:13.4
       logical name: wlx0024010c2ae6
       serial: c6:35:71:76:9b:db
       capabilities: ethernet physical wireless
       configuration: broadcast=yes driver=rt73usb driverversion=5.0.0-25-generic firmware=1.7 link=no multicast=yes wireless=IEEE 802.11
  *-network:3 DISABLED
       description: Ethernet interface
       physical id: 5
       logical name: virbr0-nic
       serial: 52:54:00:71:a9:c1
       size: 10Mbit/s
       capabilities: ethernet physical
       configuration: autonegotiation=off broadcast=yes driver=tun driverversion=1.6 duplex=full link=no multicast=yes port=twisted pair speed=10Mbit/s

"cat /etc/network/interfaces" output:

# ifupdown has been replaced by netplan(5) on this system.  See
# /etc/netplan for current configuration.
# To re-enable ifupdown on this system, you can run:
#    sudo apt install ifupdown

"cat /etc/netplan/.yaml" output

# This file describes the network interfaces available on your system
# For more information, see netplan(5).
network:
  version: 2
  renderer: networkd
  ethernets:
    enp0s31f6:
      dhcp4: yes
  bridges:
    br0:
      dhcp4: yes
      interfaces:
        - enp0s31f6

also, it says 'Ethernet Network device not managed' when I click on the network icon on top right

SPECS:

ASUS Maximus XI Hero (No Wi-Fi)
Intel Core i9 9900k @ 3.6Ghz
MSI GEFORCE RTX 2080 Ti
32GB DDR4 Ram @ 2666MHz
  • Also posted on ubuntuforums.org/showthread.php?t=2425158 – guiverc Aug 21 '19 at 12:53
  • Please try to load the kernel-module for your I219-V Lan-Chipset with "sudo modprobe e1000e". – Qterra Aug 21 '19 at 13:05
  • @Qterra, Is that supposed to give me any output on terminal? I ran that code but I feel like it didn't do anything – darky Aug 21 '19 at 13:16
  • Please update Your question with output of the sudo lshw -C network command. – Michal Przybylowicz Aug 21 '19 at 13:19
  • @darky modprobe will only generate outputs on errors. If your ethernet still not working, please add the informations Michael requested. – Qterra Aug 21 '19 at 13:31
1

In your /etc/netplan/01-netcfg.yaml file, please change both instances of enp0s31f6 to read eno1, the new logical name of your ethernet. Follow with:

sudo netplan generate
sudo netplan apply

Your ethernet should now be working correctly. If not, try a reboot.

| improve this answer | |
  • thank you so much! it worked, I can connect through ethernet now. And by the way, when I click the 'network icon' on top right, it still says Ethernet Network device not managed. is this normal? – darky Aug 21 '19 at 15:58
  • You can have it managed by Network Manager or netplan but not conveniently or easily by both. If you'd prefer Network Manager, please ask a new question and I'll advise. Bear in mind, however, that your virtual bridge is NOT easily managed by NM. If everything now works as expected, I wouldn't change a thing! – chili555 Aug 21 '19 at 16:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.