1

I did that command but only installed some applications but not installed Budgie.

I did "sudo apt-get install ubuntu-budgie-desktop" as said by Rosamunda.

What can I do now? Any body could help please?

  • 1
    Did you logout so you could choose 'Ubuntu Budgie' at the login screen? – user535733 Aug 21 '19 at 1:49
  • user535773 yes. I did. When system start up the background screen color is the color of Budgie. then appears the logo, but next appears the Grub traditional interface and that rose of Ubuntu. I thought that appears a GUI on Grub – ruiamar Aug 21 '19 at 1:56
  • Is the problem that... You want the budgie startup animation? Or you can't get to the budgie desktop? – xiota Aug 21 '19 at 2:05
  • It's more nice to see a GUI on than the traditional, but it's not a problem.The problem is that I can't get to the budgie desktop. – ruiamar Aug 21 '19 at 2:26
  • Now I found this: "askubuntu.com/questions/851793/…". I did it. Now I have to restart. – ruiamar Aug 21 '19 at 2:28
3

Budgie Desktop environment is located in standard Ubuntu universe repository since Ubuntu 18.04 LTS. So you do not need any third-party repositories or PPAs to install it.

You can install the Budgie desktop as task with

sudo add-apt-repository universe
sudo apt-get update
sudo apt-get install ubuntu-budgie-desktop^

In the last command note ^ in the end, it means installing of task with all necessary dependencies.

Then logout and select Budgie session on login screen

click on sessions select budgie session

and login to it.


If this does not help - reinstall the following packages manually:

sudo apt-get install --reinstall budgie-core budgie-desktop \
budgie-desktop-common budgie-desktop-environment \
budgie-dropby-applet budgie-hotcorners-applet budgie-indicator-applet \
budgie-keyboard-autoswitch-applet budgie-lightdm-theme \
budgie-lightdm-theme-base budgie-previews-applet budgie-quicknote-applet \
budgie-rotation-lock-applet budgie-showtime-applet budgie-wallpapers \
budgie-wallpapers-bionic gir1.2-budgie-1.0 libbudgie-plugin0 libbudgietheme0 \
libraven0 plymouth-theme-ubuntu-budgie-text plymouth-theme-ubuntu-budgie-logo \
ubuntu-budgie-desktop ubuntu-budgie-themes

Then configure LightDM as login screen with:

sudo dpkg-reconfigure lightdm # select lightdm

reboot and login to Budgie session.

| improve this answer | |
  • Problem solved. – ruiamar Aug 22 '19 at 4:32
  • This resulted in a super-responsive desktop environment - thanks so much. A massive improvement in speed of app startup and quit, on Ubu 18.04 (64bit 2GB). The budgie desktop install finished by giving an option to select lightdm, so the final line above (sudo dpkg-reconfigure lightdm # select lightdm) wasn't needed. – user517777 Jan 19 at 11:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.