0

I installed Ubuntu 18.04 on a new ASUS ROG STRIX G531GT. I tried to switch off the keyboard backlight but it didn't work. I also tried many solutions from the Internet, which didn't work:

  1. echo 0 | sudo tee /sys/class/leds/asus::kbd_backlight/brightness. It showed '/sys/class/leds/asus::kbd_backlight/brightness': No such file or directory 0

  2. xset led off .This also didn't work.

  3. I also tried these solution given in askubuntu : Turn off keyboard backlight, Asus laptop (Ubuntu 15.10)

  4. I also tried https://github.com/wroberts/rogauracore , all the code ran successfully but when I run sudo rogauracore static it shows rogauracore: command not found

Any help is appreciated. Please HELP

  • Check your BIOS. There may be a way to turn it off there. You can also try SUPER KEY+Z or FUNCTION+Z. – heynnema Aug 20 '19 at 15:39
  • @heynnema I tried with FUNCTION + Z and also with SUPER KEY + Z and also checked each and every option in BIOS. Nothing seems to work – Paras jain Aug 20 '19 at 17:08
  • Try find /sys/devices | grep -E 'kbd|brightness' Might be something there you can set to 0. However with my Asus I have to set a inotify on that file and switch it off whenever it changes. Asus seems to really like that light on. – Stephen Boston Dec 17 '19 at 6:13
0

I was having the same problem on my asus rog strix g 531gt and couldn't find a solution for a week, but in the end following the relevant section of this blog post got rogauracore working.

Setting up RGB Keyboard

As discussed above, ASUS AURA is a Windows-based application and it is bit tricky to get it working in Linux. However, thanks to Will Roberts, who developed the AURA CORE library for ROG laptops.

git clone https://github.com/wroberts/rogauracore.gitcd rogauracore
sudo apt install libusb-1.0-0 libusb-1.0-0-dev
sudo apt install autoconfautoreconf -i
./configure
make
sudo make install # Shutdown and restart the system
 Rainbow
sudo rogauracore rainbow
# Usage:
sudo rogauracore COMMAND ARGUMENTS
# COMMAND should be one of:
single_static
single_breathing
single_colorcycle
multi_static
multi_breathing
red
green
blue
yellow
cyan
magenta
white
black
rainbow

Hope it works for you too.

| improve this answer | |
0

If this link doesn't work try this one.

After downloading and extracting it to the home folder, run these commands:

cd rogauracore-retool
autoreconf -i
./configure
make
sudo make install

Hope it works for you!!

To control it:

Usage:
    sudo rogauracore COMMAND ARGUMENTS

Supported commands and usage:
   single_static COLOR
   single_breathing COLOR1 [COLOR2] [SPEED]
   single_pulsing COLOR SPEED
   single_colorcycle SPEED
   multi_static COLOR1 COLOR2 COLOR3 COLOR4
   multi_breathing COLOR1 COLOR2 COLOR3 COLOR4 SPEED
   rainbow [SPEED]
   brightness BRIGHTNESS

   red         lime        turquoise   blue        magenta     hotPink     
   orange      green       cyan        indigo      pink        white       
   yellow      teal        skyBlue     violet      deepPink    black       

COLOR argument(s) should be given as color names, or hex values like ff0000.
SPEED argument should be given as slow, medium, or fast, or integers 1 - 3.
BRIGHTNESS values should be given as off, low, medium, high, or integers 0 - 3.

If you want to turn it off:

sudo rogauracore brigtness 0
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.