2

I installed swift on my ubuntu 18.04 and when i start i get this error. but the code works fine when i'm writing them, I search some solution to fix this error but the thing is that i will remove the libc6-dbg. is it okay to remove this, and my other works wont effect after i deleted this? or should I ignore the swift error ld-2.27.so since my code working.

error: ld-2.27.so 0xffffffff0005c564: adding range [0x1464a-0x146ba) which has a base that is less than the function's low PC 0x14dc0. Please file a bug and attach the file at the start of this error message
error: ld-2.27.so 0xffffffff0005c564: adding range [0x146d0-0x146d6) which has a base that is less than the function's low PC 0x14dc0. Please file a bug and attach the file at the start of this error message
error: ld-2.27.so 0xffffffff0005c5c5: adding range [0x1464a-0x146ba) which has a base that is less than the function's low PC 0x14dc0. Please file a bug and attach the file at the start of this error message
error: ld-2.27.so 0xffffffff0005c5c5: adding range [0x146d0-0x146d6) which has a base that is less than the function's low PC 0x14dc0. Please file a bug and attach the file at the start of this error message
Welcome to Swift version 5.0.2 (swift-5.0.2-RELEASE).
2

This is a known bug: https://bugs.swift.org/browse/SR-8690

A workaround if you are not doing any debugging in glibc is to remove the debug version:

  sudo apt remove libc6-dbg
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.