0

I keep having my bluetooth turned off in ubuntu 19.04. it happens if I physically turn off or disconnect my Bluetooth speaker. Bluetooth in ubuntu 19.04 won't turn on even if the slider is on "on" mode. I have to restart ubuntu several times to make it work. I already reinstalled Bluetooth but still, it happens.

anybody here who has the same problem or have a fix for it?

thanks :)

0

Try rfkill (man rfkill)

hard vs soft block

Bluetooth in ubuntu 19.04 won't turn on even if the slider is on "on" mode.

There are two kinds of blocking radiodevices: hard and soft

  • You can check events of your device using rfkill events
  • You can check state of your device(s) using rfkill list

rfkill

rfkill is a small userspace tool to query the state of the rfkill switches, buttons and subsystem interfaces. Some devices come with a hard switch that lets you kill different types of RF radios: 802.11 / Bluetooth / NFC / UWB / WAN / WIMAX / FM. Some times these buttons may kill more than one RF type. The Linux kernel rfkill subsystem exposes these hardware buttons and lets userspace query its status and set its status through a /dev/rfkill. Given that at times some RF devices do not have hardware rfkill buttons rfkill the Linux kernel also exposes software rfkill capabilities that allows userspace to mimic a hardware rfkill event and turn on or off RF. (source)

rfkill events

  1. Open terminal
  2. Run command rfkill events
  3. Try to switch your device on|off
  4. Some command output should appear

rfkill list

  1. Open terminal
  2. Run command rfkill list
  3. You'll see states of your devices
  • ill try this, thanks :) – shootsatf8 Aug 20 at 6:44
  • tried using rfkill but its a hit or miss also,i still have to restart ubuntu or go to windows then restart to ubuntu for bluetooth work again – shootsatf8 Aug 21 at 3:22
  • @shootsatf8 sorry, but you didn't show neither any output of your commands nor some other symptoms. Please explain your case a bit more detailed. – Yasen Aug 21 at 5:42
0

I have the same problem while using bluetooth headset but reloading kernel modules can make it work without restarting.

$ sudo rmmod btusb
$ sudo modprobe btusb

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.