I keep having my bluetooth turned off in ubuntu 19.04. it happens if I physically turn off or disconnect my Bluetooth speaker. Bluetooth in ubuntu 19.04 won't turn on even if the slider is on "on" mode. I have to restart ubuntu several times to make it work. I already reinstalled Bluetooth but still, it happens.

anybody here who has the same problem or have a fix for it?

thanks :)

2 Answers 2


I have the same problem while using bluetooth headset but reloading kernel modules can make it work without restarting.

$ sudo rmmod btusb
$ sudo modprobe btusb
  • Finally something that worked.
    – nirala
    Feb 28, 2022 at 1:52

Try rfkill (man rfkill)

hard vs soft block

Bluetooth in ubuntu 19.04 won't turn on even if the slider is on "on" mode.

There are two kinds of blocking radiodevices: hard and soft

  • You can check events of your device using rfkill event
  • You can check state of your device(s) using rfkill list


rfkill is a small userspace tool to query the state of the rfkill switches, buttons and subsystem interfaces. Some devices come with a hard switch that lets you kill different types of RF radios: 802.11 / Bluetooth / NFC / UWB / WAN / WIMAX / FM. Some times these buttons may kill more than one RF type. The Linux kernel rfkill subsystem exposes these hardware buttons and lets userspace query its status and set its status through a /dev/rfkill. Given that at times some RF devices do not have hardware rfkill buttons rfkill the Linux kernel also exposes software rfkill capabilities that allows userspace to mimic a hardware rfkill event and turn on or off RF. (source)

rfkill event

  1. Open terminal
  2. Run command rfkill event
  3. Try to switch your device on|off
  4. Some command output should appear

rfkill list

  1. Open terminal
  2. Run command rfkill list
  3. You'll see states of your devices
  • the command is rfkill event.
  • tried using rfkill but its a hit or miss also,i still have to restart ubuntu or go to windows then restart to ubuntu for bluetooth work again
    – shootsatf8
    Aug 21, 2019 at 3:22
  • @shootsatf8 sorry, but you didn't show neither any output of your commands nor some other symptoms. Please explain your case a bit more detailed.
    – Yasen
    Aug 21, 2019 at 5:42
  • @Yasen hi, I've a similar problem. Here are my outputs, do you have any guess? ``` $ rfkill list 0: hci0: Bluetooth Soft blocked: no Hard blocked: no 1: phy0: Wireless LAN Soft blocked: no Hard blocked: no ```
    – FSp
    Apr 28, 2022 at 7:10
  • @FSp, your connectivity is enabled
    – Yasen
    May 21, 2022 at 9:59

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .