0

I'm getting several API errors from jujucharms:

GET https://api.jujucharms.com/charmstore/v5/~kubernetes/trusty/kubernetes-11/icon.svg 401 (Unauthorized)

When entering the URL directly I get the following:

{ Message: "access denied for user "ejperezf"", Code: "unauthorized" }

This is a fresh Juju install using Maas. I can't add bundles.

I am also getting this error:

Access to XMLHttpRequest at 'https://api.jujucharms.com/charmstore/v5/~admin/default/meta/any?include=bundle-metadata&include=bundle-machine-count&include=charm-config&include=charm-metadata&include=charm-metrics&include=common-info&include=extra-info&include=id-revision&include=manifest&include=owner&include=published&include=resources&include=revision-info&include=stats&include=supported-series&include=tags' from origin 'https://10.110.25.37:17070' has been blocked by CORS policy: Response to preflight request doesn't pass access control check: No 'Access-Control-Allow-Origin' header is present on the requested resource.

And when trying to add a bundle:

cannot fetch the entity no entity data returned, can you access the charmstore?

GET https://api.jujucharms.com/charmstore/v5/bundle/openstack-base-61/meta/any?include=bundle-metadata&include=bundle-machine-count&include=charm-config&include=charm-metadata&include=charm-metrics&include=common-info&include=extra-info&include=id-revision&include=manifest&include=owner&include=published&include=resources&include=revision-info&include=stats&include=supported-series&include=tags net::ERR_FAILED
  • Is this still affecting you? There was a outage with the charm store API, but I believe it's been resolved. – Tim McNamara Aug 29 at 7:34
  • @TimMcNamara It was an issue with the API calls that was solved in the new GUI version (v2.15.0) – Eduardo Pérez Aug 30 at 13:56
  • Really glad to hear that this has been resolved. – Tim McNamara Sep 3 at 9:52
0

Looks like just outdated links.You'd need to get into a newer supported charm to get a valid icon for it.

https://github.com/juju/juju-gui/issues/2948

  • I added more info on the errors I'm getting. – Eduardo Pérez Aug 20 at 3:28
0

It was an issue with the API calls in GUI version 2.14.0. It has been fixed in v2.15.0. Upgrade the GUI using juju upgrade-gui

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.