2

This question follows a previous question of mine here.

A user helped me to create a permanent shortcut to a folder located on the windows partition. I now can access this folder directly thanks to the shortcut but my password is asked twice when I click on it at the beginning of each session, which makes the shortcut a little less short! Actually to access any file or folder on the windows partition, I need to type my password twice.

I would like not to have to enter my password at all to access this folder through the shortcut. How can I do it? Before the actions to get a permanent shortcut, I wasn't asked my password. These actions were primarily to create a mount point by editing /etc/fstab and then to try to change the ownership of the partition but it didn't work (more details on the other question). Thanks in advance for any help!

Edit: complete /etc/fstab is:

# / was on /dev/sda6 during installation
UUID=bd39de4c-2aa3-4126-959f-b73b968d92db /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
UUID=A41F-68E2  /boot/efi       vfat    umask=0077      0       1
/swapfile                                 none            swap    sw              0       0
UUID=90EA2482EA2466A6 /media/guigeek/OS ntfs-3g  defaults,nls=utf8,fmask=117,dmask=007 uid=1000,windows-names 0 0`
  • Please post your relevant /etc/fstab entry. – ajgringo619 Aug 19 '19 at 17:40
  • You mean this: UUID=90EA2482EA2466A6 /media/guigeek/OS ntfs-3g defaults,nls=utf8,fmask=117,dm117,dmask=007 uid=1000,windows-names 0 0 ? I'm a complete newbie in Linux, so I lack much knowledge about what is what. – Guigeek Aug 19 '19 at 17:51
  • OK - what does mount | grep /media/guigeek/OS show? – ajgringo619 Aug 19 '19 at 17:53
  • 1
    Not sure why it's mounting read-only...what does ls -l /media/guigeek show? Are you dual-booting with Windows 10? If so, is Fast Boot enabled? – ajgringo619 Aug 19 '19 at 18:05
  • 1
    Delete the last (2) lines and and this (MUST be on one line): UUID=90EA2482EA2466A6 /media/guigeek/OS ntfs-3g defaults,nls=utf8,fmask=117,dm117,dmask=007,uid=1000,windows-names 0 0 – ajgringo619 Aug 19 '19 at 19:21
2

create a credential file like:

username=user
password=password

Let's say under /root/.ntfspass Put in this in your fstab file

UUID=90EA2482EA2466A6 /media/guigeek/OS ntfs-3g credentials=/root/.ntfspass,defaults,nls=utf8,fmask=117,dmask=007 uid=1000,windows-names 0 0
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.