I started off trying to update my computer and this has been now a few weekends of hell. This is a self-built desktop with an Nvidia GEForce 1070 graphics card


(primary)-display manager will not load. Currently trying sddm, but basically the same symptoms with lightdm, gdm, and slim.

(secondary)- I have Nvidia in order to run with tensorflow, but I was only able to get that working without having display and have since removed those and am not without working nvidia or display.

(tertiary) - It never shows me the grub menu - I'd be willing to scrap this thing and reboot from USB, but I can't figure it out. I can't even get into my bios, which I'm not sure if that's because I have an HDMI monitor, but it just shows blank.

  • I have tried toggling wayland
  • Installed/uninstalled nvidia drivers (430) from the repository or using their run libraries with ( I get an error: "unable to load nvidia-drm")
  • I actually upgraded from Bionic to Disco just to see if that would help
  • I've moved display managers from sddm, lightdm, slim, and gdm3
  • I realize that it keeps using nouveau and I have yet to get it to stop using nouveau despite adding to a blacklist, setting modeset=0 nomodeset=0, and nouveau.modeset=0

I would appreciate any and all help.

Hardware 7: PCI 100.0: 0300 VGA compatible controller (VGA) [Created at pci.386] <..removed for brevity.> Hardware Class: graphics card Model: "nVidia GP104 [GeForce GTX 1070]" Vendor: pci 0x10de "nVidia Corporation" Device: pci 0x1b81 "GP104 [GeForce GTX 1070]" <..removed for brevity.> Driver Info #0: Driver Status: nvidiafb is not active Driver Activation Cmd: "modprobe nvidiafb" Driver Info #1:

Driver Status: nouveau is not active
Driver Activation Cmd: "modprobe nouveau"

Driver Info #2:

Driver Status: nvidia_drm is not active
Driver Activation Cmd: "modprobe nvidia_drm"

Driver Info #3:

Driver Status: nvidia is not active
Driver Activation Cmd: "modprobe nvidia"

Config Status: cfg=new, avail=yes, need=no, active=unknown Attached to: #13 (PCI bridge)

28: PCI 02.0: 0380 Display controller [Created at pci.386] Hardware Class: graphics card Device Name: "Onboard IGD" Model: "Intel UHD Graphics 630 (Desktop)" Vendor: pci 0x8086 "Intel Corporation" Device: pci 0x3e92 "UHD Graphics 630 (Desktop)" SubVendor: pci 0x1458 "Gigabyte Technology Co., Ltd" SubDevice: pci 0xd000 Driver: "i915" Driver Modules: "i915" <..removed for brevity.>

Driver Info #0:

Driver Status: i915 is active
Driver Activation Cmd: "modprobe i915"

Config Status: cfg=new, avail=yes, need=no, active=unknown

Primary display adapter: #17

grub GRUB_DEFAULT=0 GRUB_TIMEOUT=12 GRUB_DISTRIBUTOR=lsb_release -i -s 2> /dev/null || echo Debian GRUB_CMDLINE_LINUX_DEFAULT="nouveau.modeset=0" GRUB_CMDLINE_LINUX="nouveau.modeset=0"

**modprobe sddm ** (errors) sddm.service - Simple Desktop Display Manager Loaded: loaded (/lib/systemd/system/sddm.service; indirect; vendor preset: enabled) Active: failed (Result: core-dump) since Sun 2019-08-18 19:13:20 EDT; 20s ago Docs: man:sddm(1) man:sddm.conf(5) Process: 6080 ExecStartPre=/bin/sh -c [ "$(cat /etc/X11/default-display-manager 2>/dev/null)" = "/usr/bin/sddm" ] (code=exited, status=0/SUCCESS) Process: 6082 ExecStart=/usr/bin/sddm (code=dumped, signal=ABRT) Main PID: 6082 (code=dumped, signal=ABRT)

Aug 18 19:13:18 dirac systemd[1]: sddm.service: Failed with result 'core-dump'.

Aug 18 19:13:20 dirac systemd[1]: sddm.service: Service RestartSec=1s expired, scheduling restart.

Aug 18 19:13:20 dirac systemd[1]: sddm.service: Scheduled restart job, restart counter is at 5.

Aug 18 19:13:20 dirac systemd[1]: Stopped Simple Desktop Display Manager.

Aug 18 19:13:20 dirac systemd[1]: sddm.service: Start request repeated too quickly.

Aug 18 19:13:20 dirac systemd[1]: sddm.service: Failed with result 'core- dump'.

Aug 18 19:13:20 dirac systemd[1]: Failed to start Simple Desktop Display Manager.

Aug 18 19:13:20 dirac systemd[1]: sddm.service: Triggering OnFailure= dependencies.

things I've read/tried/are reasonably close to issues I have








  • askubuntu.com/questions/1166703/… . the grub menu not showing was fixed by me editing the grub file (note I made a mistake editing the grub.cfg file ) timeouts=0 to a positive value.
    – pierrely
    Aug 19, 2019 at 3:18

1 Answer 1


I have an Acer laptop with nvidia 1080. I can share some steps that helped me getting nvidia driver and tensorflow to run (along with a functional desktop environment)

Booting the PC

If your PC freeze or shows a black screen, hit F8 after BIOS and you should see the ubuntu boot prompt. Edit the start command and add acpi=off to the boot command. On my pc this allowed to boot a one-shot usable system.

Setup nvidia drivers

  1. Add nvidia-drm.modeset=1 to GRUB_CMDLINE_LINUX_DEFAULT in /etc/default/grub. Run sudo update-grub, ensuring it run without errors.
  2. Add nvidia-drivers ppa sudo add-apt-repository ppa:graphics-drivers/ppa && sudo apt update (3). If you messed with driver before, remove everything sudo apt remove nvidia*
  3. Install a compatibile driver (there is a compatibility matrix on Nvidia website somewhere). I am using 418 (be aware that to use cuda 10 you need nvidia driver >= 410 ) sudo apt intall nvidia-driver-418 nvidia-dkms-418
  4. reboot


As playing with nvidia driver is tricky since 2006, now we also have CUDA to care about.

My personal solution is to install just the graphic card drivers and the use a docker image with CUDA in it.

This may add more complexity, but won't make unusable your tensorflow setup (or PC) at every system update.

  1. Add repository as stated here, but do not install docker yet (see next step) https://docs.docker.com/install/linux/docker-ce/ubuntu/
  2. Install nvidia docker, it will take care to pick the correct dependecy (if you are on 19.* use the 18 repos) https://github.com/NVIDIA/nvidia-docker
  3. See here to get a dockerized runtime https://www.tensorflow.org/install/docker

Hope this help

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .