0

I recently upgraded from 18.04 to 19.04 but have been unable to boot into 19.04 since the upgrade. The boot process is failing somewhere after GRUB, I get a nice graphical prompt to unlock my encrypted drive, followed by a terminal screen of [ OK ] lines and the odd [FAILED] line. These scroll too fast to see what they are, but one is Failed to start NVIDIA Persistance Daemon. I can get to the Recovery Menu and have tried re-installing nvidia drivers and also tried adding nomodeset to the GRUB config. The network DNS is broken when I drop to the root shell from the Recovery Menu but this can be fixed temporarily by modifying the /etc/resolv.conf file. If I try failsafeX I get a window stating that "Your screen, graphics card, and input device settings could not be detected correctly. You will need to configure these yourself." If I try running the default graphical mode, I get sent back to the recovery menu. The other options to configure myself, don't seem to take effect when I press OK, and just stays on the option window. I am not sure what to do at this stage. The PC is a Dell Precision M6500 laptop with an Nvidia FX2800M (G92GLM) graphics card and was working okay on 18.04 prior to the upgrade.

0

Okay, after playing around in the dark for a bit, the installation now boots. I believe the fix was to apt remove any nvidia drivers. I did however leave the xserver-xorg-video-nouveau driver installed.

Hopefully this may be of use to someone else.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.