187

System Settings can be run from the launcher (pinned by default), the Dash, or the power cog. But what command would I enter in a terminal window if I want to run it from there?

231
gnome-control-center

Note: for versions between 14.04 and 17.04, the command is unity-control-center

| improve this answer | |
  • FYI, on my Ubuntu 14.04 only gnome-control-center works. – dr_ Dec 17 '15 at 14:00
  • @dr01 I assume you are running the Gnome DE and not Unity DE then. – Elder Geek Jul 17 '18 at 15:22
  • You can still install the unity-control-center on newer versions (17.10+) if you don't like the newer gnome-control-center – mchid Apr 9 '19 at 0:02
19

if you run

gnome-control-center

and get

gnome-control-center: command not found

you can install with

sudo apt-get install gnome-control-center
| improve this answer | |
  • 2
    14.04 and greater may use the command unity-control-center instead, which was forked from it. There's no need to install gnome-control-center as well. – Christopher Kyle Horton Jul 2 '14 at 16:18
  • @WarriorIng64 cool, thanks. This was meant to help those following the accepted post that had trouble with gnome-control-center (as I did). Not sure why this post received a down vote. – grant Jul 7 '14 at 16:55
  • Thanks a lot. Sometimes I cannot find the settings icon anywhere in GNOME, perhaps for my own mistakes. With this command, I got it back. – Puspam Feb 25 at 7:32
  • My man, thank you @grant – PA-GW Sep 28 at 0:22
4

For Ubuntu Mate the command is mate-control-center.

| improve this answer | |
3

I found a different solution...

  1. I tried removing/installing gnome-control-center; this did reinstall the application I still couldn't open it.

  2. Later I found that it would start up on the side of the screen and I couldn't access it

  3. I changed the display mode to single display and it came back. Hope it helps.

| improve this answer | |
2

In Crouton, you must run anything that would require a password from the terminal, such as update manager, software center, synaptic, etc. So, to get to system settings you would enter in the terminal:

gnome-control-center

That will bring up the system settings GUI.

To check for updates, or if the update manager appears in the Unity Launcher, run it from the terminal, not by clicking on it:

sudo update-manager

The same applies to synaptic, the software center, etc. Anything which requires a password, must be run from the terminal in Crouton with a sudo.

| improve this answer | |
1

Well, in KDE NEON 5.16.4 (Ubuntu 18.04), it is written in the "System Settings Handbook":

The System Settings can be started in one of three ways:

  • By selecting Settings → System Settings from the Application Menu.
  • By pressing Alt+F2 or Alt+Space. This will bring up the KRunner dialog. Type systemsettings5, and press Enter.
  • Type systemsettings5 & at any command prompt. All three of these methods are equivalent, and produce the same result.

In my case, I needed to configure my HP LaserJet settings. Doing this as user, after applying and saving, they were ignored. So I think I had to do this as root and the settings are stored normaly now, so, each time the user opens the print dialog, the system remembers that I want log side binding and 1200 resolution :=)

I thought that sudo systemsettings5 & was enough, but as Zanna suggests: It should also be recommended to use 'sudo -H' if opening a GUI app with sudo.

| improve this answer | |
  • Why do we need sudo here? It seems like a bad idea to unnecessarily run a GUI application as root, especially using plain sudo which in most versions of Ubuntu could cause config files in a user's home to become owned by root and (in the worst case scenario) prevent the relevant software from being run by a normal user in future until the ownerships are fixed (which may be confusing for users) – Zanna Sep 12 '19 at 7:20
  • In my case, I needed to configure my HP LaserJet settings. Doing this as user, after applying and saving, it was ignored. Doing this as root, the settings are stored normaly. Now, each time the user opens the print dialog, it remembers that I want log side binding and 1200 resolution. – jimmyz Sep 12 '19 at 7:32
  • thanks for explaining. I wonder if that behaviour is normal or expected. Some system settings areas prompt me for authorisation, but most do not. I would suggest editing your answer to note that you found you needed to use sudo for this purpose for some reason. It should also be recommended to use sudo -H if opening a GUI app with sudo – Zanna Sep 12 '19 at 7:45
0

One thing no one mentions in this is if you run it from the command line you are likely to encounter errors because some environmental variables aren't being used.

First thing, you shouldn't need sudo to run the control center, but if you do make sure you run it as your user.

sudo -i gnome-control-center

Also if you run gnome-control-center without sudo it gives permission denied notes.

gnome-control-center
/sys/firmware/dmi/tables/smbios_entry_point: Permission denied
/dev/mem: Permission denied

So it is useful to know how to run it without running into issues if you are debugging something.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.