0

How to configure ubuntu 18.04 when executing systemctl hibernate password challenge is not required.

$ id -a uid=1000(user1) gid=1000(user1) groups=1000(coka),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),116(lpadmin),126(sambashare)

Please attached image.enter image description here

0

The easiest way would be to add the proper entry to sudo:

username        ALL=(ALL:ALL) NOPASSWD: /bin/systemctl hibernate
3
  • 1
    Try above. Didn't work. Aug 17 '19 at 12:59
  • sudo systemctl hibernate didn't work? I wanted something similar (for suspend), so I made an alias: alias quit='sudo systemctl suspend'. Aug 17 '19 at 15:02
  • In my case, the reason it did not work was that the tutorial I followed to enable hibernation used pkexec systemctl hibernate in the keyboard shortcut. After replacing pkexec by sudo it worked flawlessly! Jul 23 at 6:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.