2
[5.205584/ [drm:amdgpu_init [amdgpu]] *ERROR* VGACON disables amdgpu kernel modesetting.

Hello I am having this problem on my machine: I3 7100 / Asus H110M-D / RX 460 4GB / 8GB / SSD 480 and HD 1TB.

I want to migrate completely to ubuntu but found this unexpected error, researched before but did not find any post that would definitely help me.

I was able to install the system but it gets the different video drive from mine: llvmpipe (LLVM 8.0, 256 BITS).

In other versions appeared my video card and worked well now the system is slow and brittle video.

2

Been dealing with a blank screen right after boot on the same cause for days (different versions of Ubuntu-Kubuntu-LinuxMint-CentOS (both 32 and 64 bits), until I read a post on Reddit and passed this kernel parameter at boot time:

amdgpu.dc=0

My box is an A8-7680 with R7 (Wani), MSI A68HM-E33V2. Worked for me, hope it works for you!

2
  • Can you give a few more details (like the reddit link for example)?
    – damadam
    Dec 31 '19 at 8:51
  • I started it without amd drivers, they are very slow then I switched to Mint LMDE3 and I'm using it without problems. Jan 2 '20 at 22:43
1

From this thread on reddit:

I'd try booting with "amdgpu.dc=0".

This "dc" means "display core" and is problematic for some hardware setups. It was originally disabled by default, but in newer kernel versions it's enabled by default.

You can find how to try this out at boot and to make that permanent in this answer

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.