8

I am trying to get Nvidia drivers to work, however when I open Nvidia settings only a small blank window opens (shown in the screenshot along with the output from nvidia-smi command).

I have installed the driver by running the following commands:

ubuntu-drivers devices
sudo apt-get install nvidia-driver-430
sudo reboot

I have tried purging and reinstalling the driver multiple times, which didn't change anything.

Any suggestions on how to get Nvidia settings to work would be appreciated.

System: remote server with Ubuntu 18.04, with the visual output through KDE Plasma + Microsoft Remote Desktop.

Output of nvidia-smi:

+-----------------------------------------------------------------------------+
| NVIDIA-SMI 430.40       Driver Version: 430.40       CUDA Version: 10.1     |
|-------------------------------+----------------------+----------------------+
| GPU  Name        Persistence-M| Bus-Id        Disp.A | Volatile Uncorr. ECC |
| Fan  Temp  Perf  Pwr:Usage/Cap|         Memory-Usage | GPU-Util  Compute M. |
|===============================+======================+======================|
|   0  GeForce GTX 1080    Off  | 00000000:01:00.0 Off |                  N/A |
| 33%   37C    P8     7W / 200W |     54MiB /  8119MiB |      0%      Default |
+-------------------------------+----------------------+----------------------+

+-----------------------------------------------------------------------------+
| Processes:                                                       GPU Memory |
|  GPU       PID   Type   Process name                             Usage      |
|=============================================================================|
|    0      1273      G   /usr/lib/xorg/Xorg                             9MiB |
|    0      1339      G   /usr/bin/sddm-greeter                         42MiB |
+-----------------------------------------------------------------------------+

Error message when running nvidia-settings or sudo nvidia-settings:

ERROR: Unable to load info from any available system                                                                                                                               


(nvidia-settings:2278): GLib-GObject-CRITICAL **: 13:28:34.205: g_object_unref: assertion 'G_IS_OBJECT (object)' failed                                                            
** Message: 13:28:34.206: PRIME: No offloading required. Abort
** Message: 13:28:34.206: PRIME: is it supported? no

(screenshot)

3
  • 1
    I've always avoided Nvidia hardware so lack familiarity but it's possible that nvidia-settings should be run with superuser privileges (sudo). Some utility programs print vague, unhelpful errors due to not having sufficient permissions. Also, the question could be improved by editing it to also include a textual copy and past of the terminal contents. Keep the screenshot as it's useful for showing how the window is mostly blank; adding the text makes it easier to see the useful details. See unix.meta.stackexchange.com/questions/4086/… Aug 15, 2019 at 11:57
  • @AnthonyGeoghegan Thanks for the suggestions, I have edited my question accordingly. Unfortunately running with super user privileges does not change anything, giving the exact same result. Aug 15, 2019 at 12:10
  • 1
    I thought it might be worth a shot. :( All I can do is give you an upvote for asking a good/useful question and hope somebody more knowledgeable can answer it for you. Aug 15, 2019 at 12:18

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.