0

I just replaced the hard drive in my home server with a larger one, and now I get a weird not-quite-booted state. I'm running Ubuntu 16.04 LTS (yeah yeah, I know I need to update).

The procedure I used was as follows:

  1. Ran an update.
  2. Rebooted to be sure it was working.
  3. Shut down.
  4. Removed old HD from the server (called "Yemaya").
  5. Put old and new HD into an entirely different computer (called "Darth").
  6. Booted Darth off a live USB of CloneZilla.
  7. Did a device-to-device clone of from the old HD to the new HD.
  8. Shut Darth down.
  9. Booted Darth off a live USB of GParted.
  10. Expanded the partitions on the new HD to fill the available space.
  11. Shut down Darth.
  12. Removed both HDs from Darth.
  13. Put the new HD into Yemaya.
  14. Hooked it up and turned it on.

It POSTs fine:

Photo of the system's BIOS screen POST-ing.

It starts booting:

Photo of the system booting.

I allowed the fsck to run; no errors were reported any time I tried it.

Aaaaand at that point it switches to a blank, black screen.

The system is there. If I let it sit for about five minutes, eventually the monitor loses signal and starts searching for one. But if I tap any key on the keyboard, then the monitor finds a signal immediately and resumes displaying an empty black screen. So it's responding to keyboard input.

I tried SSH'ing into it, but it did not work. I can't ping it. Whatever is going wrong must be happening before the network gets started.

I can cause it to reboot by pressing CTRL+ALT+DELETE. When I do, it shows me the Ubuntu shutdown screen:

Picture of the system shutting down.

And then it reboots. I can boot it into recovery mode:

Picture of the system in recovery mode

I checked dmesg, but it had nothing interesting to say. All of my partitions mounted fine. Everything in the recovery mode console appears to work normally.

It feels like it must be a problem with the video driver, but how? I didn't touch that! The data on the disk is a bit-for-bit copy of the original. The only thing that changed was the disk capacity.

The system is rather elderly. Hardware:

  • Mainboard: Intel D945GSEJT Johnstown
  • CPU: integrated Atom processor (N270 @ 1.333 GhZ, one core, 512 KB -cache)
  • RAM: 2 GB of the fastest the board would take
  • Original HD: Western Digital Scorpio Black WD3200BEKT 320GB 7200 RPM
  • New HD: Western Digital Scorpio Black WD7500BPKT 750GB 7200 RPM
0

There appear to have been two problems.

First, the system was booting correctly, but the splash screen was never handing the display off correctly to a TTY. (This was Server Edition, and does not have a graphical UI installed).

Second, networking was failing to come up.

The solution to the first problem was to use recovery mode to turn off the splash screen, by removing "quiet splash" from the GRUB_CMDLINE_LINUX_DEFAULT line in /etc/default/grub, as per this answer, and then grub-update and reboot. Once I did that, I was able to see and read the kernel and boot messages.

The solution to the second problem turned out to be that (for some reason I still don't understand), Ubuntu forgot the name of my network interface. Its device name is eno1, but when I looked in /etc/network/interfaces, I discovered that the file had been rewritten to point at eth0, an interface that does not exist in my machine. Once I changed it back to eno1 the network came right up and all was well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.