0

I was basically doing the same thing as this guy, but haven't been as lucky. When I got to the same step in the same tutorial, I also had errors, and as that thread was the only thing that seemed relevant, I updated from 16.04.x LTS to 18.04.3 LTS.

Unfortunately, the upgrade not only failed to resolve my problems, but also introduced new ones. Specifically, mouse and keyboard input at the login screen are now very choppy (mouse moves and freezes, several keypresses appear at once and then none for a brief period with some lost if the buffer is exceeded). The issue goes away after I log in using default settings, but if I click the gear icon during login and choose Ubuntu on Wayland, the choppiness continues inside my login session. This seems likely to indicate a Wayland problem that needs resolved.

In the meantime, in case it is useful, here is the terminal output when I run "sudo miral-app" while logged in using X (presumably, but specifically, the "Ubuntu" option vs the "Ubuntu on Wayland" option):

[2019-08-14 13:33:35.752191] <information> mirserver: Starting
[2019-08-14 13:33:35.752288] < - debug - > mirserver: Not trying logind: "DISPLAY" is set and X need not have claimed the VT
[2019-08-14 13:33:35.752527] < - debug - > mirserver: Using Linux VT subsystem for session management
[2019-08-14 13:33:35.752611] <information> mircommon: Loading modules from: /usr/lib/x86_64-linux-gnu/mir/server-platform
[2019-08-14 13:33:35.752647] <information> mircommon: Loading module: /usr/lib/x86_64-linux-gnu/mir/server-platform/server-mesa-x11.so.16
[2019-08-14 13:33:35.752665] <information> mircommon: Loading module: /usr/lib/x86_64-linux-gnu/mir/server-platform/graphics-mesa-kms.so.16
[2019-08-14 13:33:35.752679] <information> mircommon: Loading module: /usr/lib/x86_64-linux-gnu/mir/server-platform/input-evdev.so.7
[2019-08-14 13:33:35.753943] <information> mirplatform: Found graphics driver: mir:mesa-x11 (version 1.4.0) Support priority: 0
[2019-08-14 13:33:35.754644] <information> mesa-kms: EGL platform does not support EGL_KHR_platform_gbm extension
[2019-08-14 13:33:35.754816] <information> mesa-kms: Failed to claim DRM master: Invalid argument
[2019-08-14 13:33:35.754878] <information> mirplatform: Found graphics driver: mir:mesa-kms (version 1.4.0) Support priority: 0
ERROR: /build/mir-4z9EK5/mir-1.4.0/src/server/graphics/default_configuration.cpp(172): Throw in function mir::DefaultServerConfiguration::the_graphics_platform()::<lambda()>
Dynamic exception type: boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<std::runtime_error> >
std::exception::what: Exception while creating graphics platform
ERROR: /build/mir-4z9EK5/mir-1.4.0/src/platform/graphics/platform_probe.cpp(109): Throw in function std::shared_ptr<mir::SharedLibrary> mir::graphics::module_for_device(const std::vector<std::shared_ptr<mir::SharedLibrary> >&, const mir::options::ProgramOption&, const std::shared_ptr<mir::ConsoleServices>&)
Dynamic exception type: boost::exception_detail::clone_impl<boost::exception_detail::error_info_injector<std::runtime_error> >
std::exception::what: Failed to find platform for current system



waiting for wayland-0
waiting for wayland-0
waiting for wayland-0

Note that the "waiting for wayland-0" output seems to repeat endlessly if I don't terminate using CTRL+C. The output may have been the same in 16.04.x, but I didn't record it. Further, I see similar output when running the same command while logged in using the Ubuntu on Wayland setting, but the repeating message is then "waiting for wayland-1". I haven't recorded that output, either, but it is repeatable, so I can if it would be useful.

Where do I need to go and/or what do I need to do to troubleshoot this issue?

ETA: Graphics card in this system is "Aspeed AST2400 BMC"

0

There appear to be several issues here. But none of them seem to be the same as the post you linked to. Starting at the beginning:

  1. The step in the tutorial asks you to run: miral-app -kiosk -launcher 'glmark2-wayland' not "sudo miral-app".

If that also fails, then post the log from that.

  1. In the above log Mir is not given control of the graphics hardware. Please indicate what that hardware is, and if you have installed any vendor drivers.
  • While I appreciate your response and actually do have a mir-kiosk issue that I would like to troubleshoot on an Ubuntu Core device where I experience this same miral-app "waiting for wayland-0" issue if I run 18.04 LTS, I need to start a separate question for that and have not done so thus far. In this question, my concern is with the behavior of the GUI while using Wayland, and that output is only provided in case it could be relevant. Though you didn't ask specifically ask, it is because I want to troubleshoot wayland that there are no mir tags on this question. – rpseu Aug 19 at 16:35
  • Regarding (2), here is LSPCI output: "04:00.0 VGA compatible controller: ASPEED Technology, Inc. ASPEED Graphics Family (rev 30)" It is an integrated video card on a Supermicro X10SLM-F. I don't remember installing any vendor drivers, but: "cat /proc/sys/kernel/tainted" returns "12288". – rpseu Aug 19 at 17:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.