3

Ubuntu 18.04.3.

Software updater keeps asking me to install a package(s), but it gives no information about the package(s). All it says is that there is 706 kB to download and install. If I click on "Install Now", everything appears to go throug the normal install process, but it then takes me back to the same window saying there is still 706 kB to download and install.

I have attached a screenshot of what I am seeing.

Why is it doing this?

What should I do to fix this?

enter image description here

Here is the output of the command sudo apt-get upgrade --dry-run:

The following packages will be upgraded:
  libegl-mesa0 libegl1-mesa libegl1-mesa-dev libgbm1 libgl1-mesa-dev
  libgl1-mesa-dri libgl1-mesa-dri:i386 libgl1-mesa-glx libgl1-mesa-glx:i386
  libglapi-mesa libglapi-mesa:i386 libgles2-mesa-dev libglx-mesa0
  libglx-mesa0:i386 libosmesa6 libosmesa6:i386 libwayland-egl1-mesa
  libxatracker2 mesa-common-dev mesa-va-drivers mesa-vdpau-drivers qemu
  qemu-block-extra qemu-kvm qemu-system qemu-system-arm qemu-system-common
  qemu-system-mips qemu-system-misc qemu-system-ppc qemu-system-s390x
  qemu-system-sparc qemu-system-x86 qemu-user qemu-user-binfmt qemu-utils
The following packages will be DOWNGRADED:
  gdm3 gir1.2-gdm-1.0 libgdm1
36 upgraded, 0 newly installed, 3 downgraded, 0 to remove and 0 not upgraded.
Inst qemu-utils [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64]) []
Inst qemu-system-common [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64]) []
Inst qemu-block-extra [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Inst gdm3 [3.28.3-0ubuntu18.04.5pop1~1551986836~18.04~d21ecd7] (3.28.3-0ubuntu18.04.5pop1~1551986836~18.04~d21ecd7~dev System76 Stable PPA:18.04/bionic [amd64]) []
Inst libgdm1 [3.28.3-0ubuntu18.04.5pop1~1551986836~18.04~d21ecd7] (3.28.3-0ubuntu18.04.5pop1~1551986836~18.04~d21ecd7~dev System76 Stable PPA:18.04/bionic [amd64]) []
Inst gir1.2-gdm-1.0 [3.28.3-0ubuntu18.04.5pop1~1551986836~18.04~d21ecd7] (3.28.3-0ubuntu18.04.5pop1~1551986836~18.04~d21ecd7~dev System76 Stable PPA:18.04/bionic [amd64])
Inst libegl-mesa0 [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64]) []
Inst libgbm1 [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst libosmesa6:i386 [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [i386]) [libosmesa6:amd64 on libosmesa6:i386] [libosmesa6:i386 on libosmesa6:amd64] [libosmesa6:amd64 ]
Inst libosmesa6 [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64]) []
Inst libgl1-mesa-dri [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64]) [libgl1-mesa-dri:amd64 on libgl1-mesa-dri:i386] [libgl1-mesa-dri:i386 on libgl1-mesa-dri:amd64] [libgl1-mesa-dri:i386 ]
Inst libgl1-mesa-dri:i386 [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [i386]) []
Inst libglx-mesa0:i386 [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [i386]) [libglx-mesa0:amd64 on libglx-mesa0:i386] [libglx-mesa0:i386 on libglx-mesa0:amd64] [libglx-mesa0:amd64 ]
Inst libglx-mesa0 [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64]) []
Inst libglapi-mesa [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64]) [libglapi-mesa:amd64 on libglapi-mesa:i386] [libglapi-mesa:i386 on libglapi-mesa:amd64] [libglapi-mesa:i386 ]
Inst libglapi-mesa:i386 [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [i386])
Inst libegl1-mesa [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst libgl1-mesa-dev [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64]) []
Inst libegl1-mesa-dev [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64]) []
Inst mesa-common-dev [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst libgl1-mesa-glx [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64]) [libgl1-mesa-glx:amd64 on libgl1-mesa-glx:i386] [libgl1-mesa-glx:i386 on libgl1-mesa-glx:amd64] [libgl1-mesa-glx:i386 ]
Inst libgl1-mesa-glx:i386 [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [i386])
Inst libgles2-mesa-dev [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst libwayland-egl1-mesa [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst libxatracker2 [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst mesa-va-drivers [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst mesa-vdpau-drivers [19.0.2-1ubuntu1.1~18.04.2] (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Inst qemu-system-arm [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Inst qemu-system-mips [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Inst qemu-system-ppc [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Inst qemu-system-sparc [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Inst qemu-kvm [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64]) []
Inst qemu-system-x86 [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Inst qemu-system-s390x [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Inst qemu-system-misc [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Inst qemu-system [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Inst qemu-user-binfmt [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64]) []
Inst qemu-user [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Inst qemu [1:2.11+dfsg-1ubuntu7.15] (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-utils (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-system-common (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-block-extra (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf gdm3 (3.28.3-0ubuntu18.04.5pop1~1551986836~18.04~d21ecd7~dev System76 Stable PPA:18.04/bionic [amd64])
Conf libgdm1 (3.28.3-0ubuntu18.04.5pop1~1551986836~18.04~d21ecd7~dev System76 Stable PPA:18.04/bionic [amd64])
Conf gir1.2-gdm-1.0 (3.28.3-0ubuntu18.04.5pop1~1551986836~18.04~d21ecd7~dev System76 Stable PPA:18.04/bionic [amd64])
Conf libegl-mesa0 (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libgbm1 (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libosmesa6:i386 (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [i386])
Conf libosmesa6 (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libgl1-mesa-dri (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libgl1-mesa-dri:i386 (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [i386])
Conf libglx-mesa0:i386 (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [i386])
Conf libglx-mesa0 (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libglapi-mesa (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libglapi-mesa:i386 (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [i386])
Conf libegl1-mesa (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libgl1-mesa-dev (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libegl1-mesa-dev (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf mesa-common-dev (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libgl1-mesa-glx (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libgl1-mesa-glx:i386 (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [i386])
Conf libgles2-mesa-dev (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libwayland-egl1-mesa (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf libxatracker2 (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf mesa-va-drivers (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf mesa-vdpau-drivers (19.0.8-0ubuntu0~18.04.1 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-system-arm (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-system-mips (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-system-ppc (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-system-sparc (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-kvm (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-system-x86 (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-system-s390x (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-system-misc (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-system (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-user-binfmt (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu-user (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
Conf qemu (1:2.11+dfsg-1ubuntu7.17 Ubuntu:18.04/bionic-updates [amd64])
  • 3
    Open the Terminal, and run sudo apt-get upgrade --dry-run - what package(s) does it say still need updated? – Thomas Ward Aug 14 at 16:41
  • 1
    Thomas Ward - I ran that command, got a very large output, I will append it to my original question. I don't know how to interpret that output, your help is appreciated. – dln949 Aug 14 at 20:05
  • downgrading gdm3 sounds worrisome. What is this "system 76 stable ppa"? – Organic Marble Aug 14 at 20:17
  • 1
    Organic Marble, many years ago I purchased this computer from a company called System 76, they put Ubunu on the computer. They installed some of thier own software on it as well, I am not excatly sure what though. You are thinking their software may be the culprit here, I should contact their tech support? – dln949 Aug 15 at 0:18
  • @dln949 I have a System76 and I know about that PPA. It provides drivers mostly but if you bought "many years ago" you no longer need it (I know I don't). – GabrielaGarcia Aug 15 at 15:59
2

The System76 PPA was in fact the source of the issue. I spoke with System76. They explained that their PPA has the same packages as the Ubuntu repos. But because they come from a non-Ubuntu repo, Ubuntu considers them a "downgrade", even though they are the exact same version. So, I "installed" the "downgrade", the versions did not change, the strange software updater message went away, and all seems fine now.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.