i am running Ubuntu 10.04 all updated installed to date (3/28/2012) and when i connect another sata HD i get this message

the disk drive for /home is not ready yet or not present continue to wait, or press S to skip mounting or M for manual recovery

so i press S but i get this message

could not update ICEauthority file /home/username/.ICEauthority

And when a press close i get this

there is a problem with the configuration server (/usr/libconf2-4/gconf-sanity-check-2 exited with status 256)

And when a press close i get message

Nautilus could not create the following required folders :/home/username/desktop,/home/username/.Nautilus before running Nautilus, please create these folders or set permissons such that Nautilus can reach them

And finally when a press Ok at the last message it disappears and i get a blank screen with a lot of colors on it and with nothing else so i shutdown (power button ) and disconnect the HD and boot without problems so how to fix this in simple commands because i am a total Linux noob

notes -In the original error my username was in place of username i wrote (did not want to confuse anybody ) -I tried searching for this problem but a got a lot of different answers and most of them were really complicated to me and not working -I got a data HD connected and working without problems also the HD i installed Ubuntu on is Sata (maybe it helps) -Apologize for me bad English its not my mother language

here is the fstab file

/etc/fstab: static file system information.


Use 'blkid -o value -s UUID' to print the universally unique identifier

for a device; this may be used with UUID= as a more robust way to name

devices that works even if disks are added and removed. See fstab(5).


proc /proc proc nodev,noexec,nosuid 0 0

/ was on /dev/sda3 during installation

UUID=9e2c3d2d-20a2-487a-b7cf-3a13d6b1f6d8 / ext4 errors=remount-ro 0 1 /dev/sda6 /home ext4 defaults 0 2 /dev/sda5 none swap sw 0 0 /dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0

  • Does the drive boot normally when the second HD is not connected? Do you have a separate Ubuntu installation on this second HD? – Marius Mar 27 '12 at 23:04
  • yes once i disconnect the second sate HD i can boot normally (and work normally) and no i dont have Ubuntu installation nor any other OS installed on the second HD – seallussus Mar 28 '12 at 0:04
  • Two things: do you have /home/ on a separate partition? Also, can you add the contents of /etc/fstab to your answer? – Marius Mar 28 '12 at 0:07
  • yes i have /home/ separate partition and when i type /etc/fstab in terminal i get this bash: /etc/fstab: Permission denied – seallussus Mar 28 '12 at 0:30
  • /etc/fstab is just a text file. You should be able to access it by opening nautilus (the file browser) and navigating to the /etc/ folder. It should open fine when you double click on it. – Marius Mar 28 '12 at 0:34

I think I can see what your problem might be now. Ubuntu maps your drives to names like /dev/sda1, /dev/sda2, etc. The /etc/fstab file is telling Ubuntu to look for your home partition on /dev/sda6, but your new SATA drive seems to be getting assigned that label when it's connected.

If you can make sense of this page on the Ubuntu wiki, you may be able to fix your issue by replacing /dev/sda6 with your home partition's UUID in /etc/fstab.

  • i got my home partition's UUID and placed it in fstab instead of /dev/sda6 (like UUID=aef32909-03d3-414e-95bf-51f86c9cf4df in place of /dev/sda6 ) but it did not work at all and i got "serious error were found while checking the disk for /home press I to ignore or S to skip or M to manually mount " error before login and "an error occurred while mounting /home press S to skip or press M to manually mount" error so i opened the fstab file and edited the line back to /dev/sda6 and removed the second drive and ubuntu is working again but the problems still the same – seallussus Mar 28 '12 at 3:47
  • Argh, the reason I pointed you at the wiki page instead of suggesting a set of steps to go through was I didn't want you to try something that was out of your depth. I figured if you were capable of understanding the wiki page, you'd be able to sort the rest out yourself. Sorry. Just to be clear, when you replaced /dev/sda6 with the UUID, did you add UUID= at the start of it? – Marius Mar 28 '12 at 3:54
  • no u really helped me cuz before reading that wiki page i did not know what UUID mean or what the fstab file for...etc so it was really helpful in a way. yes i did add UUID= before adding the HD UUID and in another attempt i added a space and a / like the line above but still i got errors . cant i add the second HD lines manually ? i tried working from the Ubuntu cd and try Ubuntu option then(while second HD connected)i open the fstab file to copy the content about 2HD and add them to my fstab but it only had a couple of lines and it was something about swap. you can try if its not troubling – seallussus Mar 28 '12 at 4:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.