3

Context:

  • the Wifi connection works perfectly with the DHCP of the router. Only with this connection, I can navigate the web.
  • the wire connection is necessary for me to be connected directly with an embedded system. In the middle there is a Switch and the only things I do is to set up the address IP of both (laptop and embedded system). The systems speak perfectly using ssh etc. No problem here.
  • OS Xubuntu 16.04 on my laptop and a Linaro on the embedded.

Problem: When I am connected to the system with the ethernet connection, it is impossible for me to navigate on the web. I guess it is because the laptop try to access using the ethernet connection. Of course, the ethernet connection goes only to the embedded system.

Question: Can I use the ethernet only for the system and the wifi to continue to navigate the web pages? How can I do that?

Please note: I would like to use both (1) the wifi to navigate and (2) the ethernet for the embedded system AT THE SAME TIME. Separately they work perfectly

  • I will try it some hours – Leos313 Aug 14 at 13:54
  • 2
    Is the Ethernet done statically or through DHCP? If it's "Automatic" aka via DHCP then you will need to alter your system to use static addressing on the Ethernet link so you can disable the Gateway portion - that will set the default Internet route to the Wifi but then allow you to only access the resources provided on the subnet on the Ethernet side. – Thomas Ward Aug 14 at 14:00
  • The ethernet does not use dhcp but a static address assigned by me only to communicate with the embedded system – Leos313 Aug 14 at 14:25
5

I have a similar setup with an Ubuntu 18.04 LTS with both Ethernet and WiFi connection. The WiFi connects to the router and the Internet. The Ethernet cable connects to a Raspberry Pi.

For Ubuntu 16.04, this answer may be useful: Connecting PC and RaspberryPi using LAN cable

The instructions below are for Ubuntu 18.04

Go to System Setup menu > Network tab on the left margin > The cog icon for the Wired connection as shown below:

enter image description here

Go to the IPv4 tab of the Wired Connection and check the box Use this connection only for resources on its network as shown below.

enter image description here

That was all. I let the desktop assign the IP by DHCP and changed the Pi's setting to request a specific IP address from the desktop. It works for me.

If you manually assign IP addresses then do not specify any Gateway IP address in this setting. A Gateway is not needed in this setup and will confuse the kernel-level packet routing. Thanks Thomas Ward.

Hope this helps

  • +1 because it solve the problem when using ubuntu 18.04. With XUbuntu 16.04 this option does not exist. Any suggestion? – Leos313 Aug 14 at 15:51
  • 2
    I have just found it and works. And I do not use dhcp. I will write another answer with the solution on my OS! This was a great help!! thank you! – Leos313 Aug 14 at 15:59
  • @Leos313 I am glad I could point you to the right direction and you found the setting in XUbuntu 16.04. Please write your own answer and accept it as the correct one. This will help others. – user68186 Aug 14 at 16:18
1

Thanks to @user68186 I have found the solution on Xubuntu 16.04:

Double click on the network connection (in my case the little symbol of wireless on top-right)

enter image description here

Choose > Edit connection... and select the connection you want to edit (in my case the Wire Connection 1):

enter image description here

From the window that will be open, select the tab IPv4:

enter image description here

Organize the network as you prefer (in my case no DHCP but a P2P connection with a little embedded system and a switch in the middle). Now press Routes on the bottom-right side and select the option Use this connection only for resource on this network:

enter image description here

Press Ok and Save the setup.

The wifi for internet and the ethernet for the P2P are working perfectly at the same time. Thanks @user68186

protected by Thomas Ward Aug 14 at 13:59

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.