11

Installing VMware 8.0.2 64bit

Ubuntu 12.04LTS 64bit BETA

My Kernel version is: 3.2.0-20-generic

pst007x@pst007x-Aspire-5741:~$ sudo sh VMware-Workstation-Full-8.0.2- 591240.x86_64.bundle

Installs ok

When I launch I am asked to install modules which are compiled and loaded into the running kernel.

A window opens

VMware Kernel Module Updater

This fails on Virtual Network Device

ERROR LOG.

UPDATE:

PATCH.

When I try to add patch, following error:

 pst007x@pst007x-Aspire-5741:~$ sudo sh patch-modules_3.2.0.sh
 [sudo] password for pst007x: 
 patch-modules_3.2.0.sh: 27: [: workstation8.0.2: unexpected operator
 patch-modules_3.2.0.sh: 28: [: workstation8.0.2: unexpected operator
 Sorry, this script is only for VMWare WorkStation 8.0.2 or VMWare Player 4.0.2. 
 Exiting
 pst007x@pst007x-Aspire-5741:~$

I have fully un-installed, and re-installed. I am installing the correct version. Probably a problem with the patch. VMware installs perfectly on Ubuntu 11.10

This is how I uninstalled.

13

Put together this from various responses:

Move to Home folder

  1. VMware-Workstation-Full-8.0.2-591240.x86_64.bundle
  2. PATCH: patch-modules_3.2.0.sh
  3. PATCH: vmware3.2.0.patch

Patch download link (xtact contents to Home folder):

http://weltall.heliohost.org/wordpress/2012/01/26/vmware-workstation-8-0-2-player-4-0-2-fix-for-linux-kernel-3-2-and-3-3/

Install VMware

sudo sh VMware-Workstation-Full-8.0.2-591240.x86_64.bundle

Install Patch

sudo ./patch-modules_3.2.0.sh

NB: Make sure patch has an executable permission

7

To disable the version check

  • open the script *.sh in an editor (gedit)
  • scroll down to line 27
  • add "#" at the beginning of line 27,28,29
  • save the script
  • try to run the script again

or go to

  • cd /usr/lib/vmware/modules/source
  • sudo tar xvf vmnet.tar
  • This will decompress files in vmnet-only folder
  • Suppose you have the patch file at ~/Downloads/vmware802fixlinux320/vmware3.2.0.patch
  • sudo patch -p1 <~/Downloads/vmware802fixlinux320/vmware3.2.0.patch
  • sudo mv vmnet.tar vmnet.tar.bak
  • sudo tar cvf vmnet.tar vmnet-only/

Re-run the VMware Workstation or Player. In case, you might need to install

  • sudo apt-get install patch
  • or change the version at line 7/8, for example vmreqver=8.0.4 to apply the patch to vmware workstation 8.0.4 – wimh Jun 19 '12 at 14:47
2

There is known issues in trying to get VMWare workstation to install and/or work on Ubuntu 12.04 LTS. Best bet is to wait for the full release next month, or revert back to Ubuntu 11.10. I know this sounds unproductive, but I had the same issues, and I decided to revert back to Ubuntu 11.10 for the time being.

  • Found a solution (above) thanks. You are right there are bugs, but there are always bugs whether pre-release or 'finished' product. This beta release has resolved NVidia performance issues I was having, otherwise I would stick to an earlier version. Thanks :-) – pst007x Apr 1 '12 at 0:09
2

OK this patch

patch-modules_3.2.0.sh
vmware3.2.0.patch

Works perfectly the only problem was I accidentally hit the update vmware button which screwed everything up at the worst time. I tried everything also trying to uninstall vmware completely. Nothing worked till I was trying to pull the hair out of my bald head.

Then I shutdown the computer and started Ubuntu in an earlier version form the boot loader. I then reinstalled vmware then re install the patch it took! Finally I then restarted as regular Ubuntu 3.2 and it worked.

Even through you uninstall vmware there's something left in the 3.2 kernel or something

2

Same situation here: Correct version of VMPlayer and patch is still claiming that it is not the correct version.

My solution: I have skipped the versioncheck in patch-modules_3.2.0.sh by uncommenting the following lines with a "#". After uncommenting the lines the patch works and my player ist now working.

[ -z "$vmver" ] && error "VMWare is not installed (properly) on this PC"

[ "$vmver" == "workstation$vmreqver" ] && product="VMWare WorkStation"

[ "$vmver" == "player$plreqver" ] && product="VMWare Player"

[ -z "$product" ] && error "Sorry, this script is only for VMWare WorkStation $vmreqver or VMWare Player $plreqver"

Be careful with my answer. After rebooting my system, I have an empty desktop and I can't even do a simple ls command in an terminal.

1

You may be interested in this workaround

http://communities.vmware.com/message/2005419

They claim to have sorted the problem of installation.

  • No, tried his patch, just says I have the wrong version, but I have installed the correct version. I posted above errors.. Thanks – pst007x Mar 27 '12 at 23:23
-6

I am running Ubuntu 10.04 LTS in VMware Workstation 8.0.2 without any issues...

Cheers!!

http://mytricks.in/2012/05/guide-how-to-install-ubuntu-12-04-lts-in-vmware-workstation-8.html

  • 2
    He is referring to the opposite, install VMWare Workstation inside Ubuntu, not Ubuntu inside VMWare. – Bruno Pereira May 21 '12 at 16:45

Not the answer you're looking for? Browse other questions tagged or ask your own question.