7

On my fully updated Ubuntu 18.04.3 system, audio doesn't work unless I switch between outputs. When I boot my PC, the right output (stereo speakers) is already selected by default, but there is no audio from Chromium, Firefox, VLC or any other program. However, the GNOME speakers test works. I can hear "front left" and "front right" from there, but no audio from other programs. In order to fix that, I can simply switch to another audio output (e.g. HDMI out) and then switch back to the stereo speakers, and the audio will magically work. Any idea why? It's not a big deal because it takes a couple of seconds to switch between outputs, but it's kind of annoying to do that after every reboot.

3
  • Is this something new that append lately or it was like this since you first installed Ubuntu on your machine? – Raffa Aug 14 '19 at 7:59
  • It started happening yesterday. My Ubuntu install is a few months old and is quite minimal, as I only have a few essential programs installed. I didn't change anything, only updated the system as I do every 2-3 days or so. – otpabu Aug 14 '19 at 8:07
  • I found that this solution worked - seems to be fine now askubuntu.com/questions/963756/… – Robert Miller Aug 17 '19 at 15:50
17

Option # 1:

Please, run in the terminal:

sudo alsa force-reload

This will reload ALSA sound driver modules in case they were modified by an upgrade, reinstall or install for example and the old ones are still in use as users tend to avoid reboots sometimes or do not think a reboot is needed after such upgrades.


Option # 2:

Please, run in the terminal:

alsamixer

You will then be presented with a screen like this:

enter image description here

Please, check if the speakers or any audio output is muted and unmute it.

MM means mute and OO means unmute.

Then exit when done by pressing Esc


Option # 3:

Old pulseaudio configuration files can sometimes get corrupted or conflict with newer versions of pulseaudio after package / system upgrades. To fix this please follow the steps below:

  • Back up ~/.config/pulse/ configuration directory to ~/.config/pulse_old/ by running the following command in the terminal:
mv  ~/.config/pulse/ ~/.config/pulse_old/
  • After that, reboot your system to build new pulseaudio configuration files. A new ~/.config/pulse/ directory will be created automatically.

  • Test your audio now.

If, somehow, after applying this fix you decide to go back to the previous state before applying the fix, please follow the steps below:

  1. Run the following command in the terminal:
rm -r  ~/.config/pulse/
  1. Run the following command in the terminal:
mv  ~/.config/pulse_old/ ~/.config/pulse/
  1. Reboot your system.

However, if all is okay and the problem is fixed, you can remove the backed up old configuration directory ~/.config/pulse_old/ to free space ( if you wish ) by running the following command in the terminal:

rm -r  ~/.config/pulse_old/
10
  • 3
    Option #3 worked for me! Thank you! – ivizot Apr 28 '20 at 12:08
  • 1
    Wait, wouldn't with method 2 you end up losing all the packages that depend on alsa-base and pulseaudio, like ubuntu-desktop metapackage? It seems to me that you would. – Alexey May 4 '20 at 8:34
  • 1
    @Alexey Yes, that's what happened in my case and the pulseaudio-module-bluetooth package got uninstalled. – Bhaskar May 4 '20 at 8:52
  • 1
    @raffa you're the man! Option #3 did it for me (updgrade 18.04 => 20.04) – undefinederror Jun 5 '20 at 10:31
  • 1
    option 3 worked for me on Ubuntu 20.04LTS : I could connect to my bluetooth speaker but even thoug I chose it as sound output, the sound would still come out of my HDMI screen. Now it works : thank you ! – Polypheme Nov 5 '20 at 23:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.