So this might get tagged as a duplicate question, but I haven't seen a post that addresses both issues.

I've installed Ubuntu 18.04. The latest version comes with kernel . With this kernel touchpad works flawlessly, but none of the fixes for the wifi seem to work (have the rtl8821ce chip).

I then installed kernel 4.15 and with this kernel I am able to get the wifi working, but I can't seem to get touchpad to work. The fixes I am able to find are to upgrade the kernel, but when I update kernel I lose wifi.

I've been trying with different kernels, and it seems anything above 5.0 will recognize the touchpad but won't allow me to compile the wifi drivers (get errors during make, and during dkms-install.sh), and seems everything above 4.15 but under 5.0 will have wifi working, but no touchpad.

From what I read, seems starting with kernel 5.0 lenovo touchpad drivers will be recognized, and the rtl8821ce driver project was abandoned by Tom on Feb 2019.

What are my options? Is my only option to wait for someone to fix the issue with a new kernel? Or is there something I can do.

  • Boot into the 4.15 kernel and post results for dmesg | grep i2c from terminal – Jeremy31 Aug 13 '19 at 20:43
  • Seems this is my first post here so still getting used to replies and such. I didn't catch your reply until now. Thank you for your willingness to help. For those that might find this post to find a solution to their problem. The command you asked me to run would have told us if the touchpad was being detected. For what it is worth at one point I did run that command and it was being detected. – CancunManny Aug 14 '19 at 6:13

Ok, so I figured it out. Will take time to share my different steps so hopefully someone else in my situation can also fix their problem. Maybe someone with a much better understanding can explain a bit better what happened.

Did new install of Ubuntu 18.04, and it had kernel 5.something. Touchpad was working great, but tried all the different instructions to get wireless going an nothing. (at the build time it would give errors)

Read a post that mentioned they got wireless working with kernel 4.15 so I downloaded kernel 4.15 (downloading the .deb files).

So I boot up with kernel 4.15, and touchpad and wireless where not working. I went ahead and tried one of the wireless fixes, and it compiled correctly and had wireless working, but no touchpad.

I then started downloading different kernels, for the most part all the 4.xx kernels I tried would have wireless working without having to do anything. Basically I didn't have to recompile anything, nor did I have to put in my wireless password.

All the 4.xx would have wireless working as soon as I started up the computer but not the touchpad, and all the different 5.xx kernels would have touchpad working, but no wireless.

Today I finally installed ukuu to help me manage the kernels. I had a long list of kernels so I started to delete them.

I think I ended up deleting the kernel version where I first got the wireless to work, and after I rebooted with a different 4.xx noticed the wifi didn't turn on. At fist it seemed like a bad thing. I had read that kernel 4.19 did seem to recognize the touchpad. I had tried it before but it didn't work (but the wireless was working).

So I went ahead and downloaded kernel 14.19.66, when I booted up noticed touchpad was working, but no internet.

I went ahead and ran the instructions on this link How to install Wi-Fi driver for Realtek RTL8821CE on Ubuntu 18.04? it did compile with no errors. Rebooted the computer, and finally ended up with working wireless and touchpad.

I had tried kernel 4.19.66 before (.66 is the newest 4.19 kernel) and wireless was working, but not the touchpad. Seems that by deleting the kernel I originally used to get wireless to work, allowed kernel 4.19.66 to recognize the touchpad, but not the wireless, but once I applied the fix on kernel 4.19.66 I was able to get wireless working again without losing the touchpad.

Hope this make sense to someone that might have the same issue.


I found out that even with an external usb WIFI key both get blocked at hardware level. I have a brand new Lenovo Ideapad S145 with clean Ubuntu 18.04.2 LTS installed.

You can check this blocking issue with the next command:


It should list something like this

$ rfkill 
 0 bluetooth hci0   unblocked unblocked
 1 wlan      phy0   unblocked blocked

Notice the blocked under the HARD column for the wlan.

You could then try do black list the mod 'ideapad_laptop' as explained in this thread:

Wifi doesnt work on fresh ubuntu 16.04

So just enter this in terminal:

sudo tee /etc/modprobe.d/blacklist-ideapad.conf <<< "blacklist ideapad_laptop"

After applying this fix and rebooting, the wifi network was working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.