Sorry if this is a repetitive or stupid question, but I couldn't seem to find anything on the internet that worked with this exact situation.

I'm currently running Ubuntu 18.04, and it recently opened up Software Updater with an update for Ubuntu, as usual. But when I try to actually update, it always closes with:

The package system is broken

Check if you are using third party repositories. If so disable them, since they are a common source of problems. Furthermore run the following command in a Terminal: apt-get install -f Transaction failed: The package system is broken The following packages have unmet dependencies:

libgl1-mesa-dev: Depends: mesa-common-dev (= 19.1.2-0~b~padoka0) but 19.0.1-3~b~padoka0 is installed

This same sort of message about unmet dependencies, libgl1-mesa-dev, and the too far updated version of mesa-common-dev happens whenever I try to install or update any packages. I have tried using the command prompted in the error message, but it doesn't work. I couldn't find anything else on the internet that worked either, and I'm really stuck right now.

If anyone has any information on how to fix this, or any useful information that I could still give, I am completely open to pretty much any suggestion. Thanks!

EDIT #1 - Here's the output of

dpkg -l | grep padoka


and of

apt-cache policy mesa-common-dev libgl1-mesa-dev


  • Please add output of dpkg -l | grep padoka and apt-cache policy mesa-common-dev libgl1-mesa-dev to the question. It seems that you use some third-party repository or PPA... – N0rbert Aug 13 at 18:18
  • Alright, I got those command outputs added. Thanks again for your help! – August Ehrlich Aug 13 at 19:53

I'll suggest to purge the problematic ppa:paulo-miguel-dias/pkppa PPA:

sudo apt-get install ppa-purge
sudo ppa-purge ppa:paulo-miguel-dias/pkppa

and use packages from official repositories.

  • Unfortunately, trying to install ppa-purge causes the same error I am trying to correct. I think somehow this error fires whenever I try to install or update anything (for sure, and it might happen with other things too, I just haven't quite checked). Is it necessary to use ppa-purge, or can I remove the ppa using another method and have a similar result? – August Ehrlich Aug 13 at 21:55
  • You can try to install packages from repositories with sudo apt-get install --allow-downgrades --reinstall mesa-common-dev=19.0.2-1ubuntu1.1~18.04.2 libgl1-mesa-dev=19.0.2-1ubuntu1.1~18.04.2 and then retry PPA purging. – N0rbert Aug 14 at 8:31
  • Unfortunately again, running the above command also gives me an error along the same lines as before, worded slightly different, but still with the same package (this is the error part, pastebin.com/kbMCtkWk). I'm beginning to think that it somehow broke something with apt as a whole, and I may need a way to manually fix that. – August Ehrlich Aug 14 at 22:53
  • Then you have to install the package with overwrite: sudo dpkg -i --force-all /var/cache/apt/archives/mesa-common-dev_19.0.2-1ubuntu1.1~18.04.2_amd64.deb. – N0rbert Aug 15 at 8:28
  • Alright thank you! This seemed to fix it! Thanks for taking the time to help me out! – August Ehrlich Aug 15 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.