3

I am trying to update my GPU driver in order to use OpenGL 4+ (Ubuntu 18.04). I have installed the recommended Nvidia driver, however when I run

glxinfo | grep OpenGL

I still get the following output:

OpenGL vendor string: VMware, Inc.
OpenGL renderer string: llvmpipe (LLVM 8.0, 256 bits)
OpenGL core profile version string: 3.3 (Core Profile) Mesa 19.0.2
OpenGL core profile shading language version string: 3.30
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.1 Mesa 19.0.2
OpenGL shading language version string: 1.40
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 19.0.2
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

Showing that OpenGL is still on Mesa and llvmpipe renderer string, instead of showing the Nvidia GPU.

When I check which drivers are used, I get the following output:

01:00.0 VGA compatible controller: NVIDIA Corporation GP104 [GeForce GTX 1080] (rev a1) (prog-if 00 [VGA controller])
    Subsystem: Micro-Star International Co., Ltd. [MSI] GP104 [GeForce GTX 1080]
    Flags: bus master, fast devsel, latency 0, IRQ 125
    Memory at ee000000 (32-bit, non-prefetchable) [size=16M]
    Memory at d0000000 (64-bit, prefetchable) [size=256M]
    Memory at e0000000 (64-bit, prefetchable) [size=32M]
    I/O ports at e000 [size=128]
    [virtual] Expansion ROM at 000c0000 [disabled] [size=128K]
    Capabilities: <access denied>
    Kernel driver in use: nvidia
    Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia

Additionally, I am unable to run nvidia-settings, as this error pops up:

ERROR: Unable to load info from any available system


(nvidia-settings:2470): GLib-GObject-CRITICAL **: 18:39:28.467: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
** Message: 18:39:28.469: PRIME: No offloading required. Abort
** Message: 18:39:28.469: PRIME: is it supported? no

Any help would be appreciated.

Edit:

Some extra information:

Result of running nvidia-smi

This is the recommended nvidia driver, installed by running sudo apt install nvidia-driver-430 and rebooting the system (sudo reboot).

I have also updated the error message shown when running nvidia-settings

Not sure if it is useful information, but the system runs on a remote server, which I am accessing using a remote desktop with Plasma KDE.

  • 2
    Please edit your question and add more detail for us. What is the recommended NVIDIA driver that you installed? Where did you install it from? What does the output of nvidia-smi show? Also, have you rebooted since you installed the NVIDIA drivers? – Terrance Aug 13 at 14:04
  • @Terrance added more information in the post as per your request – Ivan Novikov Aug 13 at 16:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.