0

I don't understand why my computer connects to my VPN at startup.

In searching online, I learned in the file /etc/default/openvpn you can edit whether all, some, or no vpn services will launch at startup (by uncomenting/completing these lines):

#AUTOSTART="all"
#AUTOSTART="none"
#AUTOSTART="home office"

However, when all 3 of these are commented out, my computer still connects to the VPN by default. By the way, I have one .conf file in the directory /etc/openvpn.

Are there other settings somewhere that are driving for it to connect at startup?

2

The file /etc/default/openvpn, try setting it this way...

#AUTOSTART="all"
AUTOSTART="none"
#AUTOSTART="home office"

In terminal, open nm-connection-editor and check the following setting... using your own connection profile...

enter image description here

You can also check the Startup Applications app to make sure that there are no defined VPN startups there.

Lastly, check ~/.config/autostart to make sure there are no defined VPN startups there.

  • I don't have wired capabilities on this computer, I don't have "editing wired connection with VPN." Also, autostart folder is empty. I am just surprised that with everything commented out in /etc/default/openvpn, that the vpn connection still autostarts. – whitelightning Aug 13 at 16:46
  • The Wired Connection with VPN image was just to show you where the VPN setting is located. That's why it's circled in red for you. Reread my answer... you don't leave "everything commented out in /etc/default/openvpn". – heynnema Aug 13 at 18:19
  • In the editing the "wifi connection" "general" tab, the box to automatically connect is unchecked. Anyway, my original question is why does the VPN automatically connect at startup when we have not specified. We seem to have specified for it not to do so, in 3 places. – whitelightning Aug 13 at 18:36
  • 1
    @whitelightning have you edited /etc/default/openvpn as my answer shows? It sounds like you haven't. Am I wrong? You could also remove the .conf from /etc/openvpn. – heynnema Aug 13 at 18:44
  • Modifying that file does result in the system not connecting at boot. My question was more along the lines of why is the default the way it is? Or is there some other setting somewhere that changes the default. – whitelightning Aug 13 at 19:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.