0

First I tried fdisk, I tried

fdisk /dev/sdb

linux is installed in this ssd

then I hit 'n' and it says: all space for primary partition is in use And I can't do anything after that.

Then I opened gparted and tried to create a new partition that way, and the new partition option is grayed out. enter image description here I'm running from boot media, because I heard you can't edit partition while it's mounted.

I have no efi partition from my previous windows installation. And I can't boot Xubuntu without a bootloader The ssd is MBR. Can I create an efi partition on my HDD, a separate hard drive and will it work from there? Because I'm able to create new partitions from the hdd. But oddly not from ssd why?

9
  • 2
    You need to resize the existing partition first.
    – Pilot6
    Aug 12 '19 at 17:24
  • Resize the existing partition got it.
    – Path
    Aug 12 '19 at 17:35
  • Wait even after resizing partition, it says 'other partitions already cover whole disk' after typing 'n' and picking a partition number 1 2 3 are out of range and 4 gives the above message.
    – Path
    Aug 12 '19 at 17:54
  • You need to have empty space to create another partition. You obviously can't create a partition when there is no space.
    – Pilot6
    Aug 12 '19 at 17:56
  • There is unallocated space on my ssd.
    – Path
    Aug 12 '19 at 17:58
0

From the screenshot, it looks like you're trying to edit the USB disk (6GB used + 16 GB free = 24 GB total) on which Ubuntu is installed.

Even if it would be an old and very small SSD, trying to change the partitions of an OS that is currently running on it would be similar to try and perform an operation on yourself, in your living room with a kitchen knife.

Dear patient, please go to the operating room and boot Ubuntu Live from another USB stick and perform a sterile operation. ;-) (Follow the duplicate, please) Posting this as an answer as there is not enough space in the comments...

3
  • I was running it from a USB stick, which was clarified in my original post. I ended up fixing it on my own thanks for the help!
    – Path
    Aug 16 '19 at 18:36
  • Did the duplicate help or did you solve it completely differently?
    – Fabby
    Aug 16 '19 at 20:41
  • I solved it differently by downloading Xubuntu 64 bit after resizing partition for space to make efi and it worked, but now I have another big problem, which deserves it's own post.
    – Path
    Aug 16 '19 at 22:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.