14

I'm using Google Suite and I have added my Google drive to Ubuntu online accounts.

I can see my Google drive and its content when I open the File Explorer. I have tried and successfully given all permissions from Google to Ubuntu gnome online accounts.

The problem is that I cannot see or add my shared drives, is there a way to do that?

2

3 Answers 3

7

Update Q1 2022: this seems to be possible with current versions of Gnome: Screenshot showing Shared drives enter image description here


This is currently (Q3 2019) not possible without additional (non-free or non-oss) software.

There are open issues on Gnome's GitLab issue tracker:

as well as on ODrives Github issue tracker:

At least insync (commercial) claims to give offline access to Google's Shared Drives for flexible and productive workflows. There may be support in other commercial offerings.

6
  • 2
    Looks like this will come natively with Ubuntu 21.04, according to the second link (gvfs #377). Only one more week to wait 😀.
    – Didier L
    Commented Apr 14, 2021 at 19:09
  • @DidierL can you verify that shared drives area available in Ubuntu 21.04? Can this functionality be achieved by upgrading Gnome in Ubuntu 20.04?
    – Stefan_EOX
    Commented Apr 1, 2022 at 10:42
  • @Stefan_EOX this comment on the second issue from the list above claims that this feature is available in Ubuntu 21.04.
    – René
    Commented Apr 1, 2022 at 15:51
  • 1
    @Stefan_EOX yes it works now, I see a "Shared with me" folder. I don’t think you can upgrade Gnome without upgrading the rest. If you are ready to go that way, why wouldn’t you switch to a non-LTS Ubuntu version?
    – Didier L
    Commented Apr 1, 2022 at 20:06
  • General afraidness, I guess, stops me from updating Ubuntu. ;-) Thanks for your confirmation. Btw, the next LTS is said to be available by 21st of April '22: omgubuntu.co.uk/2022/01/ubuntu-22-04-release-features
    – Stefan_EOX
    Commented Apr 4, 2022 at 6:46
0

I was having the same issue, but reading the answer above in late 2023 I was confused why it was not working for me on the latest Gnome Version on ArchLinux.

Rebooting my PC fixed it for me. The additional "shared drives" suddenly appeared.

0

I'm at 20.04 and I'm able to mount/view shared gdrives. Go to your mountpoint and then your .share directory. Your shared files are here, but the visibility/syncing is a little odd. (I'm still figuringing it out.)

I had made a symlink elsewhere for convenient access to some of my shared directories. However, "find -L" didn't always work. I had to "tickle" the shared directories by cd-ing into them from the .shared mountpoint.

I'm guessing the syncing/mounting of shared files is more casual than the files you own.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .