0

recent windows convert, so apologies if I'm not across a lot of the terminology.

I'm using Kubuntu 19.04 on my laptop, which is a mix of personal and work use.

When at work, most of my job is done in remote desktop sessions (RDC) on Windows servers.

Currently I'm using KRDC as my remote session client, but today I noticed the same problem working on a local QEMU/Virt-Manager VM.

When I am full screened in a remote session, and I press the Meta key (or windows key) in order to open the start menu on the remote session, the key press is being grabbed by my laptop OS. This results in the application launcher opening in Plasma, which pulls the session out of full screen. The key press is also being passed to the remote session, as the remote windows start menu will also open.

THis is obviously extremely disruptive, as it affects all meta+ shortcuts, such as opening the run command or explorer.

How can I prevent my laptop OS from intercepting and acting on the meta key presses when I am full screen in a remote session?

I'm not even sure where to start looking for answers, whether it's application specific or a global keyboard setting. I'm also having trouble phrasing the problem in order to search.

Thank you for any help.

1

Setup your Apllication Launcher to open up when you press Alt + F1 Setup Application Launcher Shortcut

Edit ~/.config/kwinrc with your prefered text editor and find the line:

[ModifierOnlyShortcuts]

If you use the default Dock edit it to:

[ModifierOnlyShortcuts]
Meta=

If you use Latte Dock edit it to:

[ModifierOnlyShortcuts]
Meta=org.kde.lattedock,/Latte,org.kde.LatteDock,

Then restart kwin with kwin_x11 --replace & disown

This is only a workaround because now you always have to use Alt + F1 to upen the Application Launcher.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.