3

Ubuntu 18.04 Gnome 3.28.2 (with the default Mutter, I believe)

The workspace switcher animation is nice, and I find the switcher overlay useful, but it takes too long for my workflow. I am not asking how to eliminate the animation or the switcher overlay. Rather, I want to make the animation faster. There are two parts of the animation:

  1. The workspace moves up/down and another slides into place behind it.
  2. The overlay displays a representation of moving between workspaces and then sits on top of the new workspace for about a second after part 1 finishes.

I am generally concerned about the first part, but reducing the duration of both would be needed for optimal functionality.

Background information (as I understand it) for future help-seakers: the workspace switcher is a component of Mutter, which is used by the GNOME Shell to manage windows. GNOME shell is the default desktop environment for Ubuntu 18.04.

4
  • 1
    Maybe you could use dconf-editor or gsettings list-recursively | grep -i animatto search for something like animat. The results would indicate what you may modify. As an unrelated example: org.gnome.shell.extensions.dash-to-dock animation-time 0.20000000000000001.
    – DK Bose
    Aug 11 '19 at 2:11
  • Nothing there, unfortunately. Aug 14 '19 at 22:09
  • I found org.freedesktop.ibus.general switcher-delay-time, but I am not sure if freedesktop is something GNOME uses or is a separate desktop environment. Either way, changing that does nothing to the workplace-switcher time in GNOME. Aug 14 '19 at 22:19
  • 2
    If you install GNOME Tweaks (which should be available in the software centre, if not it shouldn't be hard to install via apt-get or similar tools) then the Appearance category has the option to turn on and off all animations. It won't get rid of the overlay lag, but it will get rid of the sliding animation. This may not be exactly what you are looking for, if you are concerned about one animation, you may be concerned about others. GNOME Tweaks is made by the same people as the rest of GNOME stuff, so this is a fairly "legitimate" solution.
    – twoerd
    Sep 30 '19 at 2:40
0

I found an extension that disables the pop up. Not exactly what you wanted but it may help you. You probably already solved it, but if not, here is a link to the gnome extensions website. There is an extension that does what you need. Here: https://extensions.gnome.org/extension/959/disable-workspace-switcher-popup/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.