13

When trying the install Ubuntu on my old PC, I get the below following error.

Probing for devices to install to failed
-------------------------------------------------
Unfortunately probing for devices to install to failed. Please report a bug on Launchpadm and if possible include the contents of the /var/log/installer directory.

I tried to google the error but goggle does not seems to have the answer either.

System Specifications:

  • Toshiba Satellite C640-I4016
  • Core i3 1st Gen
  • 2 GB RAM
  • 500 GB hard disk

This is while attempting to install Ubuntu Server 18.04.3 LTS. It is a Live Bootable USB made using Rufus.

5
  • I don't actually see a question, however if I have issues or want to look at how a machine may run Ubuntu, I usually boot a desktop 'live' release of Ubuntu (flavor on servers commonly have low-end graphics that don't meet requirements for gnome) and look for issues there. Because desktop releases have the same base as Ubuntu server, I get a clue on how I expect it'll go, and what issues I may run into. You also didn't tell us the release, nor which version of Server you tried (as some hardware needs specific installers and some releases have multiple install options/ISOs)
    – guiverc
    Aug 10, 2019 at 6:45
  • Have updated the question with the ubuntu version. Aug 10, 2019 at 9:25
  • The 'live' server version has fewer capabilities than the standard installer (but includes 'live' function for other uses), so I'd suggest trying a different version of Ubuntu 18.04.3 server from ubuntu.com/download/server (if you clicked 'download' last time, click the 'alternative downloads' button first for other options...) - tutorials.ubuntu.com/tutorial/tutorial-install-ubuntu-server#0 may also be useful
    – guiverc
    Aug 10, 2019 at 9:29
  • Let me try downloading from alternative downloads and follow along the installation tutorial and see how it goes. Aug 10, 2019 at 9:35
  • An alternate download worked. Thanks for helping me out. :) Aug 10, 2019 at 13:05

7 Answers 7

11

The 'live' server version has fewer capabilities than the standard installer (but includes 'live' function for other uses that is really useful at times), so I'd suggest trying a different version of Ubuntu 18.04.3 server from https://ubuntu.com/download/server

If you clicked 'download' last time, click the 'alternative downloads' button first for other options...)

The following may also be useful - https://tutorials.ubuntu.com/tutorial/tutorial-install-ubuntu-server#0

This is just comments copied from above (that worked)

2
  • As of Ubuntu 22.04, there appears to only be one supported server installation image anymore, which is the "live-server" one. The 'standard installer' and the 'mini.iso' (referenced in another answer) are no longer produced, it seems.
    – James
    Jan 21, 2023 at 17:57
  • 1
    @James, I wrote the final section on "Future of MinimalCD" on the wiki (June 2021) - help.ubuntu.com/community/Installation/MinimalCD giving reasons why it's not produced any longer (it was never officially supported; a by-product of no-longer used build procedures); my source is listed in page-history. The debian installer build is the retired process that caused it to be built. Also FYI: The live installer is vastly improved over what it was when I wrote this answer; ie. the need for di installs is history.
    – guiverc
    Jan 21, 2023 at 21:53
7

Basically the server live boot images are garbage, that or Ubuntu really hates installing on write-protected USB stick. Instead, use the net installer mini.iso the latest is 73 MB, and you can get it here.

Zero problems during install, btw the other answers/suggestions were useless.

5
  • I created an account just to say Thank you so freaking much. This was it. I didn't realize the live installer was useless haha
    – Juan
    Oct 25, 2019 at 0:32
  • Thank you, the net installer is indeed much better.
    – Hendrik
    Dec 14, 2019 at 17:29
  • Thank you! The net installer is similar to the old ubuntu installer. Which is much better than the live version!!!!!
    – Q. Qiao
    Feb 11, 2021 at 3:44
  • typical... i question my sanity installing OS that comes with a broken installer by default. but not my server, not my choice. Mar 29, 2022 at 19:38
  • Per this page discourse.ubuntu.com/t/netbooting-the-live-server-installer/…, the last Ubuntu version with a mini.iso was 20.04 LTS (Focal Fossa). Beginning with 22.04.1 LTS, apparently as a result of an underlying change, the mini.iso is no longer available and the "live-server" ISO is the only server install produced by Canonical. Sadly, this change makes errors like the OP's much more difficult to work around.
    – James
    Jan 21, 2023 at 18:01
2

Removal of the NVMe worked for me too. Problem was the small screw that held the drive in place fell into the power supply. Just turned the computer upside down, gave it a shake and the screw came out.

3
  • ha !! that screw ... Nov 13, 2019 at 4:11
  • Amazing. I went to shell and and did modprobe -r nvme, then the installer was seeing my disks. btw. lsblk is good for checking which disks should be accessible Mar 17, 2020 at 14:23
  • And this also helped me: saying "NO" to the question if the installer should automatically be updated Mar 17, 2020 at 14:53
1

I had the same error today, disabling JMicron SATA controller in BIOS solved the issue.

In my case hard disks (both SATA) were visible in the system (/dev/sda and /dev/sdb) and I was able to access them via cfdisk, but the installer was failiing with the message "Probing for devices to install to failed". My motherboard (an old Asus) has 4 SATA ports handled by mobo's chipset and also an additional JMicron controller which provides PATA, one extra SATA port and one eSATA.

1

I ran into this error today as well, and worked around it by temporary removal of the NVMe disks from the system (I was planning to install to a plain SATA disk)

1

I had the same issue to install Ubuntu Server 18.04.3 on several SD cards. As guiverc suggested, using the network installer image, AKA mini.iso, from alternate downloads instead of the standard image worked but it took much more time. A better solution for me was to re-format the installation destination media, in my case delete the partitions on my SD card, and try again.

1

This was such an annoying error to encounter! What worked for me was to download the "Alternative Ubuntu Server installer", which has all the partitioning options, and it had no problem whatsoever. The default iso with the "live-server" in its name apparently is lacking something.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .