2

I was setting up a TOR connection and all of a sudden I can't connect to anything. I've uninstalled TOR and I can't get connected to my wireless router.

The icon shows connection, and nmcli general says everything is working, but I can't get it to ACTUALLY work. I've included some of the information. I'm probably missing something so if you see what you need is missing, I will edit this.

I have restarted NMCLI, network-manager, NetworkManager, wifi radio on/off, ifup/ifdown, etc.

None of the usual things are working.

Uname - version 5.0.0-23-generic

lspci -

0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no

ifconfig:

enp1s0: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 4c:72:b9:9d:fe:f3  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

lo: flags=73<UP,LOOPBACK,RUNNING>  mtu 65536
        inet 127.0.0.1  netmask 255.0.0.0
        inet6 ::1  prefixlen 128  scopeid 0x10<host>
        loop  txqueuelen 1000  (Local Loopback)
        RX packets 12322  bytes 895314 (895.3 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 12322  bytes 895314 (895.3 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

wlp3s0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.0.128  netmask 255.255.255.0  broadcast 192.168.0.255
        inet6 fe80::2268:9dff:fe54:7e42  prefixlen 64  scopeid 0x20<link>
        ether 20:68:9d:54:7e:42  txqueuelen 1000  (Ethernet)
        RX packets 4509  bytes 272210 (272.2 KB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 493  bytes 64787 (64.7 KB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

iwconfig:

wlp3s0    IEEE 802.11  ESSID:"Countess"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: CC:40:D0:D3:56:84   
          Bit Rate=1 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=64/70  Signal level=-46 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:2  Invalid misc:56   Missed beacon:0

lshw:

  *-network
       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:01:00.0
       logical name: enp1s0
       version: 0b
       serial: 4c:72:b9:9d:fe:f3
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 duplex=half firmware=rtl8168f-2_0.0.4 03/27/12 latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:17 ioport:e000(size=256) memory:d0004000-d0004fff memory:d0000000-d0003fff
  *-network
       description: Wireless interface
       product: AR9462 Wireless Network Adapter
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: wlp3s0
       version: 01
       serial: 20:68:9d:54:7e:42
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list rom ethernet physical wireless
       configuration: broadcast=yes driver=ath9k driverversion=5.0.0-23-generic firmware=N/A ip=192.168.0.128 latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:16 memory:fea00000-fea7ffff memory:fea80000-fea8ffff

nmcli general:

STATE      CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN    
connected  full          enabled  enabled  enabled  enabled 

Device info:

> GENERAL.DEVICE:                         wlp3s0 GENERAL.TYPE:          
> wifi GENERAL.HWADDR:                         20:68:9D:54:7E:42
> GENERAL.MTU:                            1500 GENERAL.STATE:           
> 100 (connected) GENERAL.CONNECTION:                     Countess
> GENERAL.CON-PATH:                      
> /org/freedesktop/NetworkManager/ActiveConnection/1 IP4.ADDRESS[1]:    
> 192.168.0.128/24 IP4.GATEWAY:                            192.168.0.1 IP4.ROUTE[1]:                           dst = 0.0.0.0/0, nh =
> 192.168.0.1, mt = 600 IP4.ROUTE[2]:                           dst = 192.168.0.0/24, nh = 0.0.0.0, mt = 600 IP4.ROUTE[3]:                           dst = 169.254.0.0/16, nh = 0.0.0.0, mt = 1000 IP4.DNS[1]:             
> 24.229.54.212 IP4.DNS[2]:                             204.186.110.76 IP4.DNS[3]:                             204.186.0.180 IP4.DNS[4]:     
> 8.8.8.8 IP4.DNS[5]:                             8.8.4.4 IP6.ADDRESS[1]:                         fe80::2268:9dff:fe54:7e42/64
> IP6.GATEWAY:                            -- IP6.ROUTE[1]:              
> dst = ff00::/8, nh = ::, mt = 256, table=255 IP6.ROUTE[2]:            
> dst = fe80::/64, nh = ::, mt = 256
  • You've done a great job of listing a lot of useful information here. It may not add much to figuring this out but I was wondering what the result of route is. I believe tor adjusts your routing so it is possible your route has not been properly restored. – RaidPinata Aug 8 '19 at 21:34
  • Did you try to reboot? – mchid Aug 8 '19 at 21:45
  • Welcome to Ask Ubuntu! ;-) Please edit your question to provide the output of sudo ufw status and sudo iptables --list. – Fabby Aug 10 '19 at 19:34
  • @Fabby The status is inactive. I've noticed that upon booting it will default to the UFW being active - and that was the cause of the problem. – Bob pickett Aug 11 '19 at 21:50
0

The UFW was enabled which for some reason, just blocked EVERYTHING on my system. I tried to establish a policy to allow TOR and ZeroNet, but it looks like I've botched everything up.

| improve this answer | |
  • If someone points you in the right direction, and then you convert a comment to an answer without asking them first if they want to answer , that is frowned upon here... – Fabby Aug 11 '19 at 22:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.