4

So recently I've been having issues with suspend on both of my ubuntu machines but the laptop is more important so I'll start there. My laptop on 18.04.2 recently got an update for kernel 5.0.0-23. Once updated the machine worked fine until I closed the lid. I noticed that the laptop wasn't suspending. I checked all the normal suspects.

I tried systemctl suspend and the screen goes blank but the power light stays lit where it would normally blink when sleeping. I am unable to get the system to come back on unless I hit the power button. When I check dmesg I find "PM: suspend entry (s2idle)".

This is odd because cat /sys/power/mem_sleep returns "s2idle [deep]"

Meanwhile if I attempt sudo pm-suspend the screen goes out and almost immediately turns back on. In this case dmesg reports "PM: suspend entry (deep)" but it jumps right to "PM: Syncing filesystems" and goes from there.

I've tried disabling all enabled devices with /proc/acpi/wakeup and messing with the power settings in gnome settings to no avail. Meanwhile if I boot up the last 4.18 kernel the laptop will suspend without any issues.

Any ideas as to what could be going on or any other information I could provide? Thank you.

0

There might be many reasons for this like hardware issues, firmware issues. If your problem is related to Kernel . Then we (Dumb Minds ) figured the solution for it.

For Linux like systems with kernel 5.x or above are facing this issue. The misconfigured source code in the Kernel is the reason for this. To get rid of this you need to patch(suspend patch) the kernel with the one that is working fine. So patch the suspend part of kernel with 5.0.18 .

We do check this on many systems with all major kernel versions. All the process and files are provided in the link below. Please follow that link for perfect answer , till now we didn’t get any major errors even if you get please let us know at. Facebook Youtube.

Video : link

Not the answer you're looking for? Browse other questions tagged or ask your own question.