0

Since I installed Lubuntu as my main OS (removed Windows which worked fine for years) I get random crashes. Sometimes before the crash I get visual artifacts (for example when moving a window) but most times it straight up crashes. This results in a black screen and the audio crashing on the way it loops the last second forever. The crash folder is empty. I have tried disabling my overclock and XMP and unpluging and plugging back the GPU cables but nothing helped. I also ran update and upgrade. The crashes sometimes continually happen at the loading screen but sometimes occur much later.

EDIT: This bug is not specific to Lubuntu as it is caused by the AMD dpm I have an AMD GPU and an intel CPU and am running Lubunu 19.04

  • It reads like hardware issues to me, esp. if you were overclocking. I would firstly check your ram (ie. run memtest a couple of times over), then do a cap-check of your motherboard etc... (ie. it reads like hardware issues to me). You could also boot a 'live' system (I'd suggest something that is not Lubuntu, not even the same release of your Lubuntu) and validate your system using a different environment - but I'd be looking at your hardware. – guiverc Aug 8 at 12:12
  • I tried reverting the overclock (and I ran memtest 86 when I got the PC) Furthermore it ran stable on windows for years. I do not have a multi meter, so I don't think I can do a cap check (also the massive heat sink is covering most of the motherboard). I tried Ubuntu once before and it was fine. I will try installing it again but it will take a while since I will need to do it through Lubuntu (without it crashing half way through) – User Aug 8 at 12:28
  • Overclocking puts extra strain on components and so shortens the life - it was this I was thinking about (thus working for years only proves age & thus increases signifance of your comment). A cap-check requires only reasonable eye-sight (but is hardware related and off-topic on this site). Before re-installing Lubuntu please use `check disc for defects* as seen in the manual (top picture of manual.lubuntu.me/1/1.3/installation.html to ensure download of ISO & write-to-media was flawless) – guiverc Aug 8 at 12:33
  • Thanks, I will try a cap-check. I doubt it happened exacely when I installed lubuntu but will try. I checked the disc for defects but will do it again before installing Ubuntu just in case. – User Aug 8 at 14:23
  • UPDATE: memtest passed without a problem but I am getting the same issues on Ubuntu. – User Aug 8 at 21:10
1

The solution was to add radeon.dpm=0to the GRUB menu, what this does is disables the "dynamic power management" in your GPU.

The top answer of this thread tells how to edit boot options better than I could so I will just link it here: How do I add a kernel boot parameter?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.