2

I am using Ubuntu 18.04 inside the WSL. When I cd /mnt/c/ and then ls, the C drive is empty.

I am not sure if it coincided with a sudo apt-get upgrade I used inside the WSL. Could this have caused the issue?

UPDATE1: I tried to revert any package I installed today. Nothing changed.

UPDATE2: I uninstalled Ubuntu, reinstalled it an everything works fine. It must have been somehting with the symbolic links. Somehow it lost the connection to the folders inside C drive. The question is why and what.

closed as off-topic by Eliah Kagan, Zanna, Kulfy, WinEunuuchs2Unix, Fabby Aug 10 at 20:16

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced, that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Eliah Kagan, Zanna, Kulfy, WinEunuuchs2Unix, Fabby
If this question can be reworded to fit the rules in the help center, please edit the question.

  • I recommend you edit this question to include the output of mount and of df -h (run from inside the WSL system). – Eliah Kagan Aug 8 at 15:20
  • Unfortunately, I didn't see your comment first.I added some updates, that by uninstalling Ubuntu it worked. Could it be somehting with the symbolic links? And what? – workaround Aug 8 at 15:23
  • I'm not sure what the cause of the problem was. The current output of those commands may reveal if there's something unusual that was reproduced in the new system, but I don't know if it's really worth looking into further now. But you should update new newly installed Ubuntu system if you haven't (or at least install security updates), and if that causes the problem to come back, there will be something to work on again. Mounts in /mnt on WSL are typically DrvFs mounts; I don't think symlinks are involved. – Eliah Kagan Aug 8 at 15:30
  • @EliahKagan is the Ubuntu version in the microsoft store directly connected with the rest distributions? – workaround Aug 9 at 7:33
  • I don't quite know what you mean. If you're asking if, in the default configuration, running sudo apt update and sudo apt upgrade in Ubuntu in WSL retrieves updates from Ubuntu's official repositories even when Ubuntu was installed through the Microsoft Store, the answer is yes. – Eliah Kagan Aug 9 at 8:40