17

I have MSI MPG X570 GAMING EDGE WIFI motherboard ( ), holding AMD Ryzen 3600X Processor.

I tried original kernel 4.15 on ubuntu 18.04 Bionic, and sensors-detect could not detect any sensors.

I also tried 5.1 kernel ("Linux 5.1.0-050100-generic") and updated lm-sensor could not detect any sensors on the MB or CPU.

What am I doing wrong? I need to be able to access the CPU temperature. Is there anyway else I could achieve the same?

Thank you, DP.

15

I had the same problem with Asus x570 which uses NCT6798D chip. As discussed here the solution is:

sudo nano /etc/default/grub

add to line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

acpi_enforce_resources=lax

so this will looks now like:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_enforce_resources=lax"

save and exit nano (or any editor you prefer), then type in terminal:

sudo update-grub

and reboot. Then type in terminal again:

sudo modprobe -v nct6775

Then you will probably see something like:

nct6775: Found NCT6798D or compatible chip at 0x2e:0x290

More sensors should be visible now. You can check this by command:

sensors
2
  • 1
    I would be curious about what this actually does in the background – xjcl Nov 15 '20 at 21:54
  • 2
    @xjcl acpi_enforce_resources=lax is kernel parameter that allows legacy drivers access to resources claimed by ACPI. By default it's set to 'strict'. So first OP allowed drivers to access resource then, after reboot, using modprobe he loaded driver for this specific chip into kernel. – Draco Nov 24 '20 at 7:09
1

I don't think you're doing anything wrong; I had similar results, and I'm on kernel 5.2 on Manjaro.

Our CPUs and motherboards are just too new to work with lm_sensors for now.

If you search around, you'll find questions like this for many AMD chip generations since thermal monitoring is slow to get working at first.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.