1

ubuntu19.04 disco, monodevelop 7.8.4(build 2)

Using monodevelop, I created a new solution(form based gtk# gui application). I added a Windows.Forms.Webbrowser control to my Form1.

When I start debugging, the application quit without showing a form at all. Instead of it, monodevelop left these messages below : libgluezilla not found. To have webbrowser support, you need libgluezilla installed

But libmono-webbrowser4.0-cil is already installed in the os ( as below ).

$ sudo apt-cache search libgluezilla
 libmono-webbrowser4.0-cil - Mono Web Browser library (for CLI 4.0)

$ sudo apt-get install libmono-webbrowser4.0-cil
libmono-webbrowser4.0-cil is already latest version (6.0.0.313-0xamarin3+ubuntu1804b1) 
upgraded: 0 , installed: 0, removed: 0, pending: 39.

$ dpkg --contents libmono-webbrowser4.0-cil_6.0.0.313-0xamarin3+ubuntu1804b1_all.deb
 drwxr-xr-x root/root         0 2019-07-14 18:12 ./
 drwxr-xr-x root/root         0 2019-07-14 18:12 ./usr/
 drwxr-xr-x root/root         0 2019-07-14 18:12 ./usr/lib/
 drwxr-xr-x root/root         0 2019-07-14 18:12 ./usr/lib/mono/
 drwxr-xr-x root/root         0 2019-07-14 18:12 ./usr/lib/mono/4.5/
 drwxr-xr-x root/root         0 2019-07-14 18:12 ./usr/lib/mono/gac/
 drwxr-xr-x root/root         0 2019-07-14 18:12 ./usr/lib/mono/gac/Mono.WebBrowser/
 drwxr-xr-x root/root         0 2019-07-14 18:12 ./usr/lib/mono/gac/Mono.WebBrowser/4.0.0.0__0738eb9f132ed756/
 -rw-r--r-- root/root    166912 2019-07-14 18:12 ./usr/lib/mono/gac/Mono.WebBrowser/4.0.0.0__0738eb9f132ed756/Mono.WebBrowser.dll
 -rw-r--r-- root/root        87 2019-07-14 18:12 ./usr/lib/mono/gac/Mono.WebBrowser/4.0.0.0__0738eb9f132ed756/Mono.WebBrowser.dll.config
 drwxr-xr-x root/root         0 2019-07-14 18:12 ./usr/share/
 drwxr-xr-x root/root         0 2019-07-14 18:12 ./usr/share/doc/
 drwxr-xr-x root/root         0 2019-07-14 18:12 ./usr/share/doc/libmono-webbrowser4.0-cil/
 -rw-r--r-- root/root     14745 2019-07-14 18:12 ./usr/share/doc/libmono-webbrowser4.0-cil/changelog.Debian.gz
 -rw-r--r-- root/root     33084 2019-07-14 17:56 ./usr/share/doc/libmono-webbrowser4.0-cil/copyright
 lrwxrwxrwx root/root         0 2019-07-14 18:12 ./usr/lib/mono/4.5/Mono.WebBrowser.dll -> ../gac/Mono.WebBrowser/4.0.0.0__0738eb9f132ed756/Mono.WebBrowser.dll

In the .pkg, there is a Mono.WebBrowser.dll but there seems to be no libgluezilla* at all. Is the ubuntu pkg correct?

What is the problem and how to fix it? Why monodevelop complains and doesn't run the applications using Windows.Forms.Webbrowser control at all?

  • How did you installed MonoDevelop? Do you use PPA or third-party repository? I do not see its package in the repository – N0rbert Aug 7 at 12:27
  • I installed : 7.8.4.1-0xamarin6+ubuntu1804b1. – Minori Aug 8 at 3:43
  • I download from monodevelop official site for latest ubuntu and installed it. : 7.8.4.1-0xamarin6+ubuntu1804b1. It is for bionic(18.04) but currently no official packages for disco. Is it the cause of this issue? – Minori Aug 8 at 3:52
  • I reinstalled mono-complete package for disco. When I executed 'sudo apt-get install mono-complete' from my console, the package name 'libgluezilla' is shown as a 'recommended package'. But there seems to be NO 'libgluezilla' package in ubuntu packages at all(for all suite). Why? – Minori Aug 8 at 4:25
0

After some non-trivial searches on package search sites as pkgs.org and packages.debian.org I see that the real package name is libmono-webbrowser4.0-cil:

Description: Mono Web Browser library (for CLI 4.0) Mono is a platform for running and developing applications based on the ECMA/ISO Standards. Mono is an open source effort led by Xamarin. Mono provides a complete CLR (Common Language Runtime) including compiler and runtime, which can produce and execute CIL (Common Intermediate Language) bytecode (aka assemblies), and a class library. .
This package contains the implementation of the WebControl class based on the Mozilla engine using libgluezilla for CLI 4.0.

Ubuntu has this package in universe pocket.

This package is provided by the repository which you have added.

So you can simply install it with:

sudo apt-get install libmono-webbrowser4.0-cil

and then write your application with it.

Note: the Ubuntu 19.04 is based on Debian Buster 10. So you may try the stable-buster branch if bionic fails.

  • Tnx for your info. Do you mean that it's okay that there's a Mono.Webbrowser.dll and no libgluezilla? I reinstalled disco version of mono-complete. ubuntu doesn't supply monodevelop package but does supply mono-complete package for disco. When I tried adding a stable-buster repository for mono, I saw hundreds of packages were scheduled to be replaced. As it's very risky, I canceled to update them. Though so far no luck I'm trying to build monodevelop from the source codes. – Minori Aug 8 at 11:25
  • It seems that Mono.Webbrowser.dll was previously called as libgluezilla. I agree about the risk. I do not know exact actual solution, just tried to solve this problem on package-level. – N0rbert Aug 8 at 12:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.