1

I'm having server with 9700K and want to enable turbo-boost to get 4.9 GHz.

I've installed cpufrequtils and set performance mode.

Via 'cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_max_freq' I'm getting 3.6 GHz.

Using Ubuntu 18.04.3 LTS.

5
  • @Rinzwind Yeah, sorry...Maybe there is other options? Aug 6, 2019 at 12:17
  • 1 => means disabled. But i can't change it. Shows me an error like tee: /sys/devices/system/cpu/intel_pstate/no_turbo: Operation not permitted Aug 6, 2019 at 12:32
  • ah. then that is it See the answer.
    – Rinzwind
    Aug 6, 2019 at 12:35
  • Solved by this answer askubuntu.com/questions/619875/… Aug 6, 2019 at 13:26
  • I'm voting to close this question as off-topic because 18.04.3 is not released.
    – K7AAY
    Aug 6, 2019 at 17:08

1 Answer 1

3
cat /sys/devices/system/cpu/intel_pstate/no_turbo

needs to show a 0. To make it 0 do ...

sudo -i
echo "0" | tee /sys/devices/system/cpu/intel_pstate/no_turbo
exit
11
  • prntscr.com/op22bt still doesn't allow =(. Aug 6, 2019 at 12:36
  • Does the whole directory exist? (or maybe do a locate intel_pstate and see where it is)
    – Rinzwind
    Aug 6, 2019 at 12:38
  • Basically yeah, prntscr.com/op2516 if i'm right, don't see any troubles, hehe). Btw, thank you for your time! Aug 6, 2019 at 12:41
  • AH! you have turbo disabled in BIOS
    – Rinzwind
    Aug 6, 2019 at 12:44
  • 1
    Nope. Sorry. You can not override a bios setting from inside the OS.
    – Rinzwind
    Aug 6, 2019 at 13:18

Not the answer you're looking for? Browse other questions tagged or ask your own question.