2

I'm trying to revert my phone from ubuntu touch back to android.

As per instructions I downloaded adb, fastboot, and the official rom

I uncompressed the rom folder, opened a terminal from within said folder and did the following

user@pc:~/Downloads/hammerhead-mob30h-factory-2c178ff7/hammerhead-mob30h$ adb devices 
List of devices attached
04cd470f0b3066a0    device

user@pc:~/Downloads/hammerhead-mob30h-factory-2c178ff7/hammerhead-mob30h$ adb reboot bootloader
user@pc:~/Downloads/hammerhead-mob30h-factory-2c178ff7/hammerhead-mob30h$ ./flash-all.sh 
target reported max download size of 1073741824 bytes
sending 'bootloader' (3120 KB)...
OKAY [  0.310s]
writing 'bootloader'...
OKAY [  0.514s]
finished. total time: 0.824s
rebooting into bootloader...
OKAY [  0.100s]
finished. total time: 0.150s
target reported max download size of 1073741824 bytes
sending 'radio' (45425 KB)...
OKAY [  1.640s]
writing 'radio'...
OKAY [  3.134s]
finished. total time: 4.774s
rebooting into bootloader...
OKAY [  0.100s]
finished. total time: 0.150s
extracting android-info.txt (0 MB)...
extracting boot.img (8 MB)...
target reported max download size of 1073741824 bytes
archive does not contain 'boot.sig'
archive does not contain 'dtbo.img'
archive does not contain 'dt.img'
extracting recovery.img (9 MB)...
archive does not contain 'recovery.sig'
extracting system.img (996 MB)...
archive does not contain 'system.sig'
archive does not contain 'vbmeta.img'
archive does not contain 'vendor.img'
wiping userdata...
Couldn't parse erase-block-size '0x'.
Couldn't parse logical-block-size '0x'.
mke2fs 1.44.1 (24-Mar-2018)
/tmp/TemporaryFile-RNGfj5: Unimplemented ext2 library function while setting up superblock
/usr/lib/android-sdk/platform-tools/mke2fs failed with status 1
mke2fs failed: 1
error: Cannot generate image for userdata

user@pc:~/Downloads/hammerhead-mob30h-factory-2c178ff7/hammerhead-mob30h$ 

As far as I'm aware that's exactly what the instructions called for. I've tried searching for the error messages but come up with all kinds of unrelated thing.

Anyone know that's going wrong here?

3
  • 1
    Welcome to AskUbuntu! Please edit your question and add the following information: Which phone? Which instructions did you try to follow? Which rom did you download? – danzel Aug 6 '19 at 10:18
  • 1
    @danzel It's a Nexus 5 and one of the factory images. – dobey Aug 26 '19 at 14:51
  • 1
    Have you tried other images instead? M4B30Z is the last image available for Nexus 5, while you seem to have grabbed an interim 6.0.1 version. I had a similar problem with my Nexus 5 once, trying to flash a different Ubuntu Touch image, and I had to adb into recovery and manually format the cache partition. You might need to do similar. – dobey Aug 26 '19 at 14:53
4

Open the flash-all.sh script in an editor, scroll down to the last line which looks something like: fastboot -w update image.zip

Remove the -w flag, save the script, run it again and it should work.

3
  • 1
    This worked for me. Thanks – Naveen Jan 28 '20 at 21:34
  • 1
    worked for downgrading from pixel experience to stock google rom v8.0, thx! – flyingdrifter Dec 21 '20 at 19:49
  • I logged into Stackoverflow after a month just to upvote this answer. – Jasom Dotnet Mar 31 at 20:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.