0

So I just did a fresh install on my laptop of Ubuntu 19.04 (just minimal install, nothing special). I followed the commands on WineHQ's website as I normally do, but now I am getting an error stating

The following packages have unmet dependencies: winehq-staging : Depends: wine-staging (= 4.13~disco) E: Unable to correct problems, you have held broken packages.

Is there something going on with Wine right now that it can't install on 19.04 or am I missing something obvious?

  • Have you tried to fix the broken packages by sudo apt install -f? – pa4080 Aug 6 at 7:48
3

To give you a reputable source to download libfaudio0 from:

https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_19.04/amd64/libfaudio0_19.08-0~disco_amd64.deb

https://download.opensuse.org/repositories/Emulators:/Wine:/Debian/xUbuntu_19.04/i386/libfaudio0_19.08-0~disco_i386.deb

Then

sudo dpkg -i libfaudio0_19.08-0~disco_amd64.deb libfaudio0_19.08-0~disco_i386.deb

After that, it worked for me.

  • Not sure why suse has deb packages in their repo, but nice find. – Zulgrib Aug 10 at 16:00
  • Thanks, I just found the links on some Linux forum when I was googling the same problem. – Golden Gleam Aug 11 at 7:55
1

I've gone down the dependency chain rabbit-hole a bit and found that there is a required dependency, "libfaudio0", that does not seem to be directly supplied (currently) either by Ubuntu or WineHQ.

You will likely have to manually find the *.deb (don't forget for both amd64 and i386 if you have 32-bit enabled) from a reputable source and install it before the broken package situation can be resolved.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.