0

I just upgraded Ubuntu 16.04 to 18.04 and after reboot it shows

Gave up waiting for suspend/resume device
/: clean, 293537/3932160 files, 4067550/15719936 blocks
cryptsetup (md5_crypt): set up successfully

then it doesn't go to log in page.

Even though it hangs here, I can ssh in the computer and I can access folders and files. (one problem is terminal doesn't have the ability of interpolation and showing history command though)

My quick search on this error is telling this problem is related to swap memory. Let me share some of the command outputs here and some approaches I already tried and not worked.

$ sudo blkid | grep swap
/dev/mapper/sdb8_crypt: UUID="19a5cc43-2391-461e-9d36-ecb21d23cbe1" TYPE="swap"
/dev/mapper/sda8_crypt: UUID="a68d5301-6f0c-4069-be2b-b43d42e4697c" TYPE="swap"
$ sudo cat  /etc/initramfs-tools/conf.d/resume
#RESUME=UUID=6f0ca38b-604e-4641-8d12-c81fd8228098
#RESUME=none
RESUME=UUID=19a5cc43-2391-461e-9d36-ecb21d23cbe1
#RESUME=UUID=a68d5301-6f0c-4069-be2b-b43d42e4697c

First row was a row I had first and I commented out it then added second, third and fourth, and tried them respectively but non of them worked well with $sudo update-initramfs -u

$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
#GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_TIMEOUT_STYLE=hidden
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""
GRUB_ENABLE_CRYPTODISK=y

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"
$ sudo lsinitramfs /initrd.img |grep resume
bin/resume
conf/conf.d/resume
scripts/local-premount/resume
$ swapon
NAME      TYPE      SIZE USED PRIO
/dev/dm-2 partition  16G   0B   -2
/dev/dm-3 partition  16G   0B   -3
$ sudo update-initramfs -u
update-initramfs: Generating /boot/initrd.img-4.15.0-55-generic
cryptsetup: WARNING: resume device UUID=7bad70b9-6b90-424b-88e1-3b36e63ea23f uses a key file
W: Possible missing firmware /lib/firmware/ast_dp501_fw.bin for module ast

I saw tried the following solutions but none of them worked. Swap: From partition to file, now get "no matching swap device is available" threads I could find is similar to this)

https://fitzcarraldoblog.wordpress.com/2018/06/15/lubuntu-18-04-gave-up-waiting-for-suspend-resume-device/ (I don't have /swapfile
$ ls /swapfile
ls: cannot access '/swapfile': No such file or directory)

1
0

I think the problem is your disk is encrypted and you can't use an encrypted swap to hybernate the system.

Try to disable resume uncommenting RESUME=none in /etc/initramfs-tools/conf.d/resume and running sudo update-initramfs -u -k all. Then run sudo update-grub and reboot.

If it doesn't work check grub config with grep resume /boot/grub/grub.cfg to see if somehow some strange resume setting is ending up there despite having none in /etc/default/grub.

Edit: You can also disable resume adding the kernel paramenter noresume in /etc/default/grub.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.