0

For some reason, Ubuntu 18.04 refuses to start. It has worked previously - with some minor problems related to my Nvidia GPU drivers (which I fixed by going nomodeset and installing proprietary drivers), and later some problems with Ethernet connection (which I solved using these solutions: Issue with Ethernet dropping Connection Irregularly Ubuntu-Budgie and https://ubuntu-mate.community/t/stop-network-disconnecting-in-ubuntu/829 - I used both and I'm not sure which one was the one that worked). I haven't messed with system or system files in any way last time I turned Ubuntu on.

Currently, after the Ubuntu logo splash loading screen, the screen (filled with text) starts to flicker at regular intervals, showing these messages on screen with no change (it took like 5 minutes to take these photos because they only flicker on for a short time, then they disappear for a couple seconds, then reappear again - etc).

In recovery mode menu I tried option to "repair broken packages" - it seemingly succeeded but it didn't help at all, now different messages flicker with no change in behavior.

Here are the images: https://imgur.com/a/VU4jD4e 1-3 are the images at first, II1 - II3 are after Repair Packages attempt. If they're identical (I think they might be but I'm not sure) then I guess you have two versions of the images?

Using recovery mode simply nets "out of range/60khz" error on my display, and nomodeset does nothing, it still results in flickering text. Yesterday (last time I used Ubuntu) everything was OK.

My computer specs are:

  CPU: Intel Xeon E3120 3.16 GHz
  RAM: 4GB
  GPU: Nvidia Quadro NVS 290
  HDD: 2TB, split into two partitions (1TB Windows 10 and 1TB Ubuntu 18.04)

I'm using an external sound card, as this system (made to be a server) lacks one by default.

I'm posting this from Windows 10 on the same computer which seems unaffected (similarly GRUB works perfectly fine), so I doubt it's a hardware issue.

EDIT: Full text of the final line of text:

Started GNOME Display Manager. Dispatcher Service... system changes.pp link was shut down....

EDIT 2: I left it running for 40 minutes now, and it doesn't seem to start. Still, I will leave it running overnight. Also the screen now looks like that: https://imgur.com/a/zhoq0Uk

EDIT 3: I tried logging into text mode by replacing "quiet splash" with "text". To my surprise it did the same thing - flickering text - though with a different message:

other image

Interestingly, when I pressed Ctrl+Alt+F3, I was shown a text login screen, but after about 5 seconds it vanished and the screen started flickering again.

As for this question being a duplicate - switching the display manager to lightdm from the root shell (in recovery mode menu) seemed partially successful - I now see the login screen, but Ubuntu refuses to accept my login, as trying to login using a correct password simply causes the screen to go black, and then I'm dumped back to the login screen. However, I can press Ctrl+Alt+F3 from HERE, and this console, unlike the GUI lightdm login screen, accepts my login for some reason.

This allowed me to attempt every solution presented in GDM3 does not start in Ubuntu 18.04 - and none of them do anything - the Wayland thing, Slim solution, gnome-desktop - none of them. I tried installing and switching to Slim, but does basically the same thing as LightDM - when I type in my username and password, I get an error saying failed to execute login command, black screen, and login screen restarts. And just like with LightDM, I can use Ctrl+Alt+F3 to log into text mode.

Also I tried to get to /var/log and look at logs using less, but I can't notice any obvious errors - at least no lines claiming 'error'. It would definitely help if I was able to somehow copy those files to my Windows partition and share their content here - I guess I will look into that tomorrow.

EDIT 4: When rereading Xorg.1.log, I noticed some errors - it appears that there is a bunch of errors involving "Wacom Bamboo PT" - invalid type 'cursor for this device and similar stuff (in addition to cursor there was lasso touch, pad, stylus, eraser...). However, I'm not sure if that could be the issue as this problem occurs regardless of whether my Wacom tablet was plugged in or not.

However, later down the line I found more errors: client bug: timer event8 debounce: offset negative - that line was repeated over and over, followed by bracketed values: (-6ms), (-21ms), timer event8 debounce short offset negative (-77ms), (-14ms), (-26ms), (-32ms) and timer event8 debounce short offset negative (-46ms)

However, there was no such error in Xorg.0.log

10
  • Could you provide more information about what happened between the last time it booted successfully and now? What changed? As a first step, allow the machine time to boot. The last screen cap shows that the display manager is up and running, so the login screen should be coming up. Then see this link to resolve the network interfaces issue. – Karthik Aug 5 '19 at 17:47
  • I guess the problem you are seeing is that the display manager tries to start, fails, tries to start again, fails, etc. So your screen is switching between text mode and graphics mode all the time, that why the flickering. If you can then try to ssh into the machine and then cd /var/log. See which log files were updated most recently: ls -latr. Then have a look at those files: less some_log_file ("q" will terminate the pager). You'll probably find the error in the Xorg.0.log if you have that on your system. – Tomáš Pospíšek Aug 5 '19 at 17:55
  • Like I said, I don't believe anything has changed whatsoever. All I did in the last session was watch some Youtube videos using Firefox, and changed the screen sleep setting from 5 minutes of inactivity to 15 minutes. But thanks, I will try that. – shinobody Aug 5 '19 at 18:31
  • "If you can then try to ssh into the machine" i have no idea what that means. Looking it up nets this article: linuxize.com/post/how-to-enable-ssh-on-ubuntu-18-04 - which is definitely impossible, I can't log in to install it, nor do I have any idea how to set up a LAN or how to find out IP of the problematic machine (I'm pretty sure I have dynamic IP). – shinobody Aug 5 '19 at 19:05
  • 1
    Possible duplicate of GDM3 does not start in Ubuntu 18.04 – Gunnar Hjalmarsson Aug 5 '19 at 19:51
3

Solved! In recovery mode after enabling networking I selected dpkg - Repair broken packages, and then in root shell I used apt update and then apt dist-upgrade and this seems to have solved the problem. I'm not sure why it worked, but it worked.

1

For a future user, if above doesn't work, try below method:

mv /var/lib/gdm3 /var/lib/gdm3.old

Or, if in case, you don't want to keep OLD, you can delete them (not recommended)

rm -rf /var/lib/gdm3/*
rm -rf /var/lib/gdm3/.[a-z]*

This should fixed the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.