I tried installing anaconda3 today but was returned the following error message:

Preparing transaction: done
Executing transaction: / WARNING conda.core.envs_manager:register_env(46): Unable to register environment. Path not writable or missing.
  environment location: /home/hshows/anaconda3
  registry file: /home/hshows/.conda/environments.txt
installation finished.
Do you wish the installer to initialize Anaconda3
by running conda init? [yes|no]

I'm a stark raving noob at ubuntu so I'm not sure where to start with resolving this issue.



It seems anaconda installed properly (e.g. I am able to open a jupyter notebook), however I still would like to understand the "warning" mentioned above. Additionally when I open a new terminal now I get the word (base) in front of my terminal prompt--is this perhaps related to the warning?


It seems it is an error with the anaconda installer, reported here :


The suggested fix is to manually create the ~/.conda folder before running the installer. The GitHub issues indicates this is fixed but I had the same error today installing miniconda3.

One of the maintainers indicated that the miniconda installer will be updated within 1-2 weeks. The Anaconda installer is already fixed.


The base terminal prompt issue has nothing to due with the error message and can be resolved by setting:

conda config --set auto_activate_base false
  • Thank you Kulfy for the correction.
    – Eagle_Mike
    Sep 27 '19 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.