I am dual booting Ubuntu and I want to delete Ubuntu from my computer. In windows 10 disk management the option to delete the partition is grayed out. Does anyone have a solution to this?

screenshot of Disk Management MMC snap-in in Windows

  • 1
    We support Ubuntu and official flavors of Ubuntu here. Since you don't want to use Ubuntu anymore; you delete it within your Windows 10 system, and have windows 10 take ownership of grub/booting (if Ubuntu handled that; otherwise you won't be able to reboot windows) - but this is now a Windows issue and off-topic here - askubuntu.com/help/on-topic – guiverc Aug 5 '19 at 6:40
  • @guiverc Judging by How to remove Ubuntu and put Windows back on?, we seem to support that Windows issue on AU at least to some extent. However, that's probably not the situation here. The partition the screenshot shows is the optical drive with Ubuntu installation media in it. So we could consider this off-topic after all...but personally I hope we keep it open. The confusion here can also occur as one prepares to install Ubuntu, a use case we support in greater depth. – Eliah Kagan Aug 5 '19 at 7:54

That would appear to be the Ubuntu install disk that is still in your DVD drive. Simply eject it.

  • No, I installed it through a bootable usb. I don't know why it shows it in there. I have one hard drive and I shrunk the windows partition to half the drive space and installed Ubuntu on the other half of the drive. I have no disk in my laptop. – Zack Aug 5 '19 at 23:01
  • Ok, this is more of a windows problem then. The size of the partition suggests it is install media, not an installation. I have seen Windows display a usb drive as a CD before so it could simply be your bootable usb still inserted. I’m not a Windows expert but I’d guess you can mount an image somehow. Perhaps it’s just a file on your file system that has been mounted. If none of this resolves your issue I suggest you try a Windows forum. Would be interested to hear what it is when you have fixed it. – PonJar Aug 6 '19 at 7:48
  • Seems you can mount an image in Windows. To unmount it open file explorer. Right click your G: drive and click Eject. If this is the case there will be a 1.8G file somewhere to delete too. – PonJar Aug 6 '19 at 10:28
  • It wasn't a bootable drive of any sort. It was installed a couple of weeks ago and I've been using it, no bootable drive in the computer at all. I don't understand why it showed up as a cd drive and not on the hard drive but I ended up ejecting it and it disappeared and that was it. I have no clue where it would have been installed on my computer because I only have one hard drive and that is the only kind of storage on my computer. – Zack Aug 7 '19 at 0:01
  • I have used Ubuntu while having nothing in the computer so the only explanation is that it was running on the hard drive. I searched my entire drive for Ubuntu and nothing came up so I assume it's gone but I don't know for sure. I guess I solved my question but now I'm quite curious where Ubuntu was installed. Thanks for the help though, it's greatly appreciated. – Zack Aug 7 '19 at 0:01

I didn't think about how it was labeled as cd/rom so I right clicked on it and selected eject which seemed to do the trick.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.