1

I am running Xubuntu 18.04 kernel version 5.0.0-23-generic and using a cheap microsoft usb mouse. I also have setup imwheel with the following settings:

".*"
None, Up, Button4, 3
None, Down, Button5, 3
Control_L, Up, Control_L|Button4
Control_L, Down, Control_L|Button5
Shift_L, Up, Shift_L|Button4
Shift_L, Down, Shift_L|Button5

as per this tutorial for slow scroll speed:
http://www.webupd8.org/2015/12/how-to-change-mouse-scroll-wheel-speed.html

My problem:

when I resume from suspend the scroll wheel no longer works.

A tedious workaround I found is to unplug and replugin the usb receiver. This will bring the scrolling function back, but will not resume the imwheel settings above--the scroll speed is super slow. To get back my scroll speed settings I have to type in console: imwheel --kill to restart my imwheel settings.

Is there anyway to automate this process? My goal is to have normal scrolling when resuming from suspend without having to go thru steps above.

I am still very new to linux so any help is greatly appreciated.

EDIT: prior to removing and replacing receiver, Chrome will scroll albeit extreeeemely slowly, but other programs, such as Thunderbird will not scroll at all.

  • Your mouse seems to need to have imwheel run again, as it looks like suspend/resume didn't save/restore its state. Read man pm-action (Provided by: pm-utils_1.4.1-17_all) to see how to add your command to be run at the right time. – waltinator Aug 4 at 21:25
  • So, the imwheel --kill command only works after I remove and replace usb receiver. – Tenacious Qi Aug 5 at 18:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.